]> CyberLeo.Net >> Repos - CDN/cdn-ports-overlay.git/blob - cdn/ports/misc-cdn/bash-config/Makefile
misc-cdn/bash-config: Fix typo
[CDN/cdn-ports-overlay.git] / cdn / ports / misc-cdn / bash-config / Makefile
1 # $FreeBSD$
2
3 PORTNAME=       bash-config
4 PORTVERSION=    1.1.1
5 CATEGORIES=     misc-cdn
6 MASTER_SITES=   http://git.cyberleo.net/releases/${PORTNAME}/
7 EXTRACT_SUFX=   .tgz
8
9 MAINTAINER=     cyberleo@cyberleo.net
10 COMMENT=        A framework for easy, modular Bash environment configuration
11
12 VALID_CATEGORIES += misc-cdn
13
14 NO_BUILD=       yes
15
16 OPTIONS_DEFINE= BASHCOMP
17 BASHCOMP_DESC=  Install bash-completion scripts & depends
18 OPTIONS_DEFAULT=BASHCOMP
19
20 PLIST_FILES=    etc/bash-config/virgin \
21                 etc/bash-config/common \
22                 etc/bash-config/inputrc \
23                 etc/bash-config/bash_profile \
24                 etc/bash-config/bash_profile.d/10-inputrc \
25                 etc/bash-config/bash_profile.d/10-local-bin \
26                 etc/bash-config/bash_profile.d/10-prompt \
27                 etc/bash-config/bash_profile.d/10-title \
28                 etc/bash-config/bash_profile.d/20-flag \
29                 etc/bash-config/bash_profile.d/50-rbenv \
30                 etc/bash-config/bash_profile.d/98-dot-bash_profile \
31                 etc/bash-config/bash_profile.d/99-bashrc \
32                 etc/bash-config/bashrc \
33                 etc/bash-config/bashrc.d/00-bash_profile \
34                 etc/bash-config/bashrc.d/10-aliases \
35                 etc/bash-config/bashrc.d/10-bash-completion \
36                 etc/bash-config/bashrc.d/10-bash_history \
37                 etc/bash-config/bashrc.d/20-flag \
38                 etc/bash-config/bashrc.d/50-asdf \
39                 etc/bash-config/bashrc.d/50-rbenv \
40                 etc/bash-config/bashrc.d/50-rvm \
41                 etc/bash-config/bashrc.d/99-dot-bashrc \
42                 share/bash-config/fixskel \
43                 share/bash-config/fixuser
44
45 PLIST_DIRS=     share/bash-config \
46                 etc/bash-config/bashrc.d \
47                 etc/bash-config/bash_profile.d \
48                 etc/bash-config
49
50 RUN_DEPENDS+=   bash:${PORTSDIR}/shells/bash
51
52 .include <bsd.port.options.mk>
53
54 .if ${PORT_OPTIONS:MBASHCOMP}
55 RUN_DEPENDS+=   ${LOCALBASE}/share/bash-completion/bash_completion.sh:${PORTSDIR}/shells/bash-completion
56
57 PLIST_FILES+=   share/bash-completion/completions/service \
58                 share/bash-completion/completions/zfs
59 .endif
60
61 post-patch:
62         ${REINPLACE_CMD} -i '' -e 's|/usr/local/|${PREFIX}/|g' \
63                 ${WRKSRC}/bash-config/common \
64                 ${WRKSRC}/bash-config/bash_profile \
65                 ${WRKSRC}/bash-config/bash_profile.d/* \
66                 ${WRKSRC}/bash-config/bashrc \
67                 ${WRKSRC}/bash-config/bashrc.d/* \
68                 ${WRKSRC}/share/fixskel \
69                 ${WRKSRC}/share/fixuser
70
71 do-install:
72         ${MKDIR} ${STAGEDIR}${ETCDIR}
73         ${INSTALL_SCRIPT} ${WRKSRC}/bash-config/virgin ${STAGEDIR}${ETCDIR}
74         ${INSTALL_DATA} ${WRKSRC}/bash-config/common ${STAGEDIR}${ETCDIR}
75         ${INSTALL_DATA} ${WRKSRC}/bash-config/bash_profile ${STAGEDIR}${ETCDIR}
76         ( cd ${WRKSRC}/bash-config && ${COPYTREE_SHARE} bash_profile.d ${STAGEDIR}${ETCDIR} )
77         ${INSTALL_DATA} ${WRKSRC}/bash-config/bashrc ${STAGEDIR}${ETCDIR}
78         ( cd ${WRKSRC}/bash-config && ${COPYTREE_SHARE} bashrc.d ${STAGEDIR}${ETCDIR} )
79         ${INSTALL_DATA} ${WRKSRC}/bash-config/inputrc ${STAGEDIR}${ETCDIR}
80         ${MKDIR} ${STAGEDIR}${PREFIX}/share/bash-config
81         ${INSTALL_SCRIPT} ${WRKSRC}/share/fixskel ${STAGEDIR}${DATADIR}
82         ${INSTALL_SCRIPT} ${WRKSRC}/share/fixuser ${STAGEDIR}${DATADIR}
83 .if ${PORT_OPTIONS:MBASHCOMP}
84         ${MKDIR} ${STAGEDIR}${PREFIX}/share/bash-completion/completions
85         ${INSTALL_DATA} ${WRKSRC}/bash-completions/service ${STAGEDIR}${PREFIX}/share/bash-completion/completions
86         ${INSTALL_DATA} ${WRKSRC}/bash-completions/zfs ${STAGEDIR}${PREFIX}/share/bash-completion/completions
87 .endif
88
89 .include <bsd.port.mk>