]> CyberLeo.Net >> Repos - FreeBSD/FreeBSD.git/blob - contrib/apr-util/apr-util.spec
sysctl(9): Fix a few mandoc related issues
[FreeBSD/FreeBSD.git] / contrib / apr-util / apr-util.spec
1
2 %define apuver 1
3
4 Summary: Apache Portable Runtime Utility library
5 Name: apr-util
6 Version: 1.6.1
7 Release: 1
8 License: Apache Software License
9 Group: System Environment/Libraries
10 URL: http://apr.apache.org/
11 Source0: http://www.apache.org/dist/apr/%{name}-%{version}.tar.bz2
12 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
13 BuildRequires: autoconf, libtool, doxygen, apr-devel >= 1.4.0
14 BuildRequires: expat-devel, libuuid-devel
15
16 %description
17 The mission of the Apache Portable Runtime (APR) is to provide a
18 free library of C data structures and routines.  This library
19 contains additional utility interfaces for APR; including support
20 for XML, LDAP, database interfaces, URI parsing and more.
21
22 %package devel
23 Group: Development/Libraries
24 Summary: APR utility library development kit
25 Requires: apr-util = %{version}-%{release}, apr-devel
26 Requires: db4-devel, expat-devel
27
28 %description devel
29 This package provides the support files which can be used to 
30 build applications using the APR utility library.  The mission 
31 of the Apache Portable Runtime (APR) is to provide a free 
32 library of C data structures and routines.
33
34 %package dbm
35 Group: Development/Libraries 
36 Summary: APR utility library DBM driver
37 BuildRequires: db4-devel
38 Requires: apr-util = %{version}-%{release}
39
40 %description dbm
41 This package provides the DBM driver for the apr-util.
42
43 %package pgsql
44 Group: Development/Libraries
45 Summary: APR utility library PostgreSQL DBD driver
46 BuildRequires: postgresql-devel
47 Requires: apr-util = %{version}-%{release}
48
49 %description pgsql
50 This package provides the PostgreSQL driver for the apr-util
51 DBD (database abstraction) interface.
52
53 %package mysql
54 Group: Development/Libraries
55 Summary: APR utility library MySQL DBD driver
56 BuildRequires: mysql-devel
57 Requires: apr-util = %{version}-%{release}
58
59 %description mysql
60 This package provides the MySQL driver for the apr-util DBD
61 (database abstraction) interface.
62
63 %package sqlite
64 Group: Development/Libraries
65 Summary: APR utility library SQLite DBD driver
66 BuildRequires: sqlite-devel >= 3.0.0
67 Requires: apr-util = %{version}-%{release}
68
69 %description sqlite
70 This package provides the SQLite driver for the apr-util DBD
71 (database abstraction) interface.
72
73 %package odbc
74 Group: Development/Libraries
75 Summary: APR utility library ODBC DBD driver
76 BuildRequires: unixODBC-devel
77 Requires: apr-util = %{version}-%{release}
78
79 %description odbc
80 This package provides the ODBC driver for the apr-util DBD
81 (database abstraction) interface.
82
83 %package ldap
84 Group: Development/Libraries
85 Summary: APR utility library LDAP support
86 BuildRequires: openldap-devel
87 Requires: apr-util = %{version}-%{release}
88
89 %description ldap
90 This package provides the LDAP support for the apr-util.
91
92 %package openssl
93 Group: Development/Libraries
94 Summary: APR utility library OpenSSL crypto support
95 BuildRequires: openssl-devel
96 Requires: apr-util = %{version}-%{release}
97
98 %description openssl
99 This package provides crypto support for apr-util based on OpenSSL.
100
101 %package nss
102 Group: Development/Libraries
103 Summary: APR utility library NSS crypto support
104 BuildRequires: nss-devel
105 Requires: apr-util = %{version}-%{release}
106
107 %description nss
108 This package provides crypto support for apr-util based on Mozilla NSS.
109
110 %prep
111 %setup -q
112
113 %build
114 %configure --with-apr=%{_prefix} \
115         --includedir=%{_includedir}/apr-%{apuver} \
116         --with-ldap --without-gdbm \
117         --with-sqlite3 --with-pgsql --with-mysql --with-odbc \
118         --with-berkeley-db \
119         --with-crypto --with-openssl --with-nss \
120         --without-sqlite2
121 make %{?_smp_mflags} && make dox
122
123 %check
124 # Run non-interactive tests
125 pushd test
126 make %{?_smp_mflags} all CFLAGS=-fno-strict-aliasing
127 make check || exit 1
128 popd
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132 make install DESTDIR=$RPM_BUILD_ROOT
133
134 # Documentation
135 mv docs/dox/html html
136
137 # Unpackaged files
138 rm -f $RPM_BUILD_ROOT%{_libdir}/aprutil.exp
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post -p /sbin/ldconfig
144
145 %postun -p /sbin/ldconfig
146
147 %files
148 %defattr(-,root,root,-)
149 %doc CHANGES LICENSE NOTICE
150 %{_libdir}/libaprutil-%{apuver}.so.*
151 %dir %{_libdir}/apr-util-%{apuver}
152
153 %files dbm
154 %defattr(-,root,root,-)
155 %{_libdir}/apr-util-%{apuver}/apr_dbm_db*
156
157 %files pgsql
158 %defattr(-,root,root,-)
159 %{_libdir}/apr-util-%{apuver}/apr_dbd_pgsql*
160
161 %files mysql
162 %defattr(-,root,root,-)
163 %{_libdir}/apr-util-%{apuver}/apr_dbd_mysql*
164
165 %files sqlite
166 %defattr(-,root,root,-)
167 %{_libdir}/apr-util-%{apuver}/apr_dbd_sqlite*
168
169 %files odbc
170 %defattr(-,root,root,-)
171 %{_libdir}/apr-util-%{apuver}/apr_dbd_odbc*
172
173 %files ldap
174 %defattr(-,root,root,-)
175 %{_libdir}/apr-util-%{apuver}/apr_ldap*
176
177 %files openssl
178 %defattr(-,root,root,-)
179 %{_libdir}/apr-util-%{apuver}/apr_crypto_openssl*
180
181 %files nss
182 %defattr(-,root,root,-)
183 %{_libdir}/apr-util-%{apuver}/apr_crypto_nss*
184
185 %files devel
186 %defattr(-,root,root,-)
187 %{_bindir}/apu-%{apuver}-config
188 %{_libdir}/libaprutil-%{apuver}.*a
189 %{_libdir}/libaprutil-%{apuver}.so
190 %{_libdir}/pkgconfig/apr-util-%{apuver}.pc
191 %{_includedir}/apr-%{apuver}/*.h
192 %doc html
193
194 %changelog
195 * Tue Jun 22 2004 Graham Leggett <minfrin@sharp.fm> 1.0.0-1
196 - update to support v1.0.0 of APR
197                                                                                 
198 * Tue Jun 22 2004 Graham Leggett <minfrin@sharp.fm> 1.0.0-1
199 - derived from Fedora Core apr.spec
200