]> CyberLeo.Net >> Repos - FreeBSD/FreeBSD.git/blob - contrib/libarchive.spec
Update vendor/libarchive to git 92366744a52f3fa83c3899e375e415a5080a05f2
[FreeBSD/FreeBSD.git] / contrib / libarchive.spec
1 Summary:        Library to create and read several different archive formats
2 Name:           libarchive
3 Version:        3.1.2
4 Release:        1
5 License:        BSD
6 Group:          Libraries
7 Source0:        http://libarchive.org/downloads/%{name}-%{version}.tar.gz
8 URL:            http:/libarchive.org/
9 Requires:       glibc
10 Requires:       zlib
11 Requires:       bzip2
12 BuildRequires:  gcc
13 BuildRequires:  gcc-c++
14 BuildRequires:  gawk
15 BuildRequires:  zlib-devel
16 BuildRequires:  bzip2
17 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
18
19 %description
20 Libarchive is a programming library that can create and read several
21 different streaming archive formats, including most popular TAR
22 variants and several CPIO formats. It can also write SHAR archives.
23
24 %package devel
25 Summary:        Header files for libarchive library
26 Group:          Development/Libraries
27 Requires:       %{name} = %{version}-%{release}
28
29 %description devel
30 Header files for libarchive library.
31
32 %package static
33 Summary:        Static libarchive library
34 Group:          Development/Libraries
35 Requires:       %{name}-devel = %{version}-%{release}
36
37 %description static
38 Static libarchive library.
39
40 %package -n bsdtar
41 Summary:        bsdtar - tar(1) implementation based on libarchive
42 Group:          Applications/Archiving
43 Requires:       %{name} = %{version}-%{release}
44
45 %description -n bsdtar
46 bsdtar - tar(1) implementation based on libarchive.
47
48 %package -n bsdcpio
49 Summary:        bsdcpio - cpio(1) implementation based on libarchive
50 Group:          Applications/Archiving
51 Requires:       %{name} = %{version}-%{release}
52
53 %description -n bsdcpio
54 bsdcpio - cpio(1) implementation based on libarchive
55
56 %prep
57 %setup -q
58
59 %build
60 mkdir -p %{buildroot}
61 ./configure \
62 --prefix=%{_prefix} \
63 --libexecdir=%{_libexecdir} \
64 --libdir=%{_libdir} \
65 --mandir=%{_mandir} \
66 --infodir=%{_infodir} \
67 --enable-shared=yes \
68 --enable-static=yes \
69 | tee %{buildroot}/config.log
70 make | tee %{buildroot}/make.log
71
72 %install
73 [ "%buildroot" != "/" ] && [ -d %buildroot ] && rm -rf %buildroot;
74 make DESTDIR=%buildroot install
75
76 %clean
77 rm -fr %buildroot
78
79 %files
80 %{_libdir}/libarchive.so*
81
82 %files static
83 %{_libdir}/libarchive.a
84
85 %files devel
86 %{_libdir}/pkgconfig/libarchive.pc
87 %{_libdir}/libarchive.la
88 %{_includedir}/*.h
89 %doc %{_mandir}/man3/*
90 %doc %{_mandir}/man5/*
91
92 %files -n bsdtar
93 %attr(755,root,root) %{_bindir}/bsdtar
94 %doc %{_mandir}/man1/bsdtar.1*
95
96 %files -n bsdcpio
97 %attr(755,root,root) %{_bindir}/bsdcpio
98 %doc %{_mandir}/man1/bsdcpio.1*
99
100 %changelog
101 * Wed May 01 2013 Nikolai Lifanov <lifanov@mail.lifanov.com> - 3.1.2-1
102 - Initial package
103 - contrib/libarchive.spec by PLD team overhaul
104 - Added "bsdcpio" package
105 - Fixed build on x86_64 platform