]> CyberLeo.Net >> Repos - FreeBSD/FreeBSD.git/blob - contrib/redhat/openssh.spec
Vendor import of OpenSSH 7.8p1.
[FreeBSD/FreeBSD.git] / contrib / redhat / openssh.spec
1 %define ver 7.8p1
2 %define rel 1%{?dist}
3
4 # OpenSSH privilege separation requires a user & group ID
5 %define sshd_uid    74
6 %define sshd_gid    74
7
8 # Version of ssh-askpass
9 %define aversion 1.2.4.1
10
11 # Do we want to disable building of x11-askpass? (1=yes 0=no)
12 %define no_x11_askpass 0
13
14 # Do we want to disable building of gnome-askpass? (1=yes 0=no)
15 %define no_gnome_askpass 0
16
17 # Do we want to link against a static libcrypto? (1=yes 0=no)
18 %define static_libcrypto 0
19
20 # Do we want smartcard support (1=yes 0=no)
21 %define scard 0
22
23 # Use GTK2 instead of GNOME in gnome-ssh-askpass
24 %define gtk2 1
25
26 # Use build6x options for older RHEL builds
27 # RHEL 7 not yet supported
28 %if 0%{?rhel} > 6
29 %define build6x 0
30 %else
31 %define build6x 1
32 %endif
33
34 %if 0%{?fedora} >= 26
35 %define compat_openssl 1
36 %else
37 %define compat_openssl 0
38 %endif
39
40 # Do we want kerberos5 support (1=yes 0=no)
41 %define kerberos5 1
42
43 # Reserve options to override askpass settings with:
44 # rpm -ba|--rebuild --define 'skip_xxx 1'
45 %{?skip_x11_askpass:%define no_x11_askpass 1}
46 %{?skip_gnome_askpass:%define no_gnome_askpass 1}
47
48 # Add option to build without GTK2 for older platforms with only GTK+.
49 # RedHat <= 7.2 and Red Hat Advanced Server 2.1 are examples.
50 # rpm -ba|--rebuild --define 'no_gtk2 1'
51 %{?no_gtk2:%define gtk2 0}
52
53 # Is this a build for RHL 6.x or earlier?
54 %{?build_6x:%define build6x 1}
55
56 # If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc.
57 %if %{build6x}
58 %define _sysconfdir /etc
59 %endif
60
61 # Options for static OpenSSL link:
62 # rpm -ba|--rebuild --define "static_openssl 1"
63 %{?static_openssl:%define static_libcrypto 1}
64
65 # Options for Smartcard support: (needs libsectok and openssl-engine)
66 # rpm -ba|--rebuild --define "smartcard 1"
67 %{?smartcard:%define scard 1}
68
69 # Is this a build for the rescue CD (without PAM, with MD5)? (1=yes 0=no)
70 %define rescue 0
71 %{?build_rescue:%define rescue 1}
72
73 # Turn off some stuff for resuce builds
74 %if %{rescue}
75 %define kerberos5 0
76 %endif
77
78 Summary: The OpenSSH implementation of SSH protocol version 2.
79 Name: openssh
80 Version: %{ver}
81 %if %{rescue}
82 Release: %{rel}rescue
83 %else
84 Release: %{rel}
85 %endif
86 URL: https://www.openssh.com/portable.html
87 Source0: https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
88 Source1: http://www.jmknoble.net/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
89 License: BSD
90 Group: Applications/Internet
91 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
92 Obsoletes: ssh
93 %if %{build6x}
94 PreReq: initscripts >= 5.00
95 %else
96 Requires: initscripts >= 5.20
97 %endif
98 BuildRequires: perl
99 %if %{compat_openssl}
100 BuildRequires: compat-openssl10-devel
101 %else
102 BuildRequires: openssl-devel >= 1.0.1
103 BuildRequires: openssl-devel < 1.1
104 %endif
105 BuildRequires: /bin/login
106 %if ! %{build6x}
107 BuildRequires: glibc-devel, pam
108 %else
109 BuildRequires: /usr/include/security/pam_appl.h
110 %endif
111 %if ! %{no_x11_askpass}
112 BuildRequires: /usr/include/X11/Xlib.h
113 # Xt development tools
114 BuildRequires: libXt-devel
115 # Provides xmkmf
116 BuildRequires: imake
117 # Rely on relatively recent gtk
118 BuildRequires: gtk2-devel
119 %endif
120 %if ! %{no_gnome_askpass}
121 BuildRequires: pkgconfig
122 %endif
123 %if %{kerberos5}
124 BuildRequires: krb5-devel
125 BuildRequires: krb5-libs
126 %endif
127
128 %package clients
129 Summary: OpenSSH clients.
130 Requires: openssh = %{version}-%{release}
131 Group: Applications/Internet
132 Obsoletes: ssh-clients
133
134 %package server
135 Summary: The OpenSSH server daemon.
136 Group: System Environment/Daemons
137 Obsoletes: ssh-server
138 Requires: openssh = %{version}-%{release}, chkconfig >= 0.9
139 %if ! %{build6x}
140 Requires: /etc/pam.d/system-auth
141 %endif
142
143 %package askpass
144 Summary: A passphrase dialog for OpenSSH and X.
145 Group: Applications/Internet
146 Requires: openssh = %{version}-%{release}
147 Obsoletes: ssh-extras
148
149 %package askpass-gnome
150 Summary: A passphrase dialog for OpenSSH, X, and GNOME.
151 Group: Applications/Internet
152 Requires: openssh = %{version}-%{release}
153 Obsoletes: ssh-extras
154
155 %description
156 SSH (Secure SHell) is a program for logging into and executing
157 commands on a remote machine. SSH is intended to replace rlogin and
158 rsh, and to provide secure encrypted communications between two
159 untrusted hosts over an insecure network. X11 connections and
160 arbitrary TCP/IP ports can also be forwarded over the secure channel.
161
162 OpenSSH is OpenBSD's version of the last free version of SSH, bringing
163 it up to date in terms of security and features, as well as removing
164 all patented algorithms to separate libraries.
165
166 This package includes the core files necessary for both the OpenSSH
167 client and server. To make this package useful, you should also
168 install openssh-clients, openssh-server, or both.
169
170 %description clients
171 OpenSSH is a free version of SSH (Secure SHell), a program for logging
172 into and executing commands on a remote machine. This package includes
173 the clients necessary to make encrypted connections to SSH servers.
174 You'll also need to install the openssh package on OpenSSH clients.
175
176 %description server
177 OpenSSH is a free version of SSH (Secure SHell), a program for logging
178 into and executing commands on a remote machine. This package contains
179 the secure shell daemon (sshd). The sshd daemon allows SSH clients to
180 securely connect to your SSH server. You also need to have the openssh
181 package installed.
182
183 %description askpass
184 OpenSSH is a free version of SSH (Secure SHell), a program for logging
185 into and executing commands on a remote machine. This package contains
186 an X11 passphrase dialog for OpenSSH.
187
188 %description askpass-gnome
189 OpenSSH is a free version of SSH (Secure SHell), a program for logging
190 into and executing commands on a remote machine. This package contains
191 an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
192 environment.
193
194 %prep
195
196 %if ! %{no_x11_askpass}
197 %setup -q -a 1
198 %else
199 %setup -q
200 %endif
201
202 %build
203 %if %{rescue}
204 CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
205 %endif
206
207 %configure \
208         --sysconfdir=%{_sysconfdir}/ssh \
209         --libexecdir=%{_libexecdir}/openssh \
210         --datadir=%{_datadir}/openssh \
211         --with-default-path=/usr/local/bin:/bin:/usr/bin \
212         --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
213         --with-privsep-path=%{_var}/empty/sshd \
214         --with-md5-passwords \
215         --mandir=%{_mandir} \
216         --with-mantype=man \
217         --disable-strip \
218 %if %{scard}
219         --with-smartcard \
220 %endif
221 %if %{rescue}
222         --without-pam \
223 %else
224         --with-pam \
225 %endif
226 %if %{kerberos5}
227          --with-kerberos5=$K5DIR \
228 %endif
229
230
231 %if %{static_libcrypto}
232 perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
233 %endif
234
235 make
236
237 %if ! %{no_x11_askpass}
238 pushd x11-ssh-askpass-%{aversion}
239 %configure --libexecdir=%{_libexecdir}/openssh
240 xmkmf -a
241 make
242 popd
243 %endif
244
245 # Define a variable to toggle gnome1/gtk2 building.  This is necessary
246 # because RPM doesn't handle nested %if statements.
247 %if %{gtk2}
248         gtk2=yes
249 %else
250         gtk2=no
251 %endif
252
253 %if ! %{no_gnome_askpass}
254 pushd contrib
255 if [ $gtk2 = yes ] ; then
256         make gnome-ssh-askpass2
257         mv gnome-ssh-askpass2 gnome-ssh-askpass
258 else
259         make gnome-ssh-askpass1
260         mv gnome-ssh-askpass1 gnome-ssh-askpass
261 fi
262 popd
263 %endif
264
265 %install
266 rm -rf $RPM_BUILD_ROOT
267 mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
268 mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
269 mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
270
271 make install DESTDIR=$RPM_BUILD_ROOT
272
273 install -d $RPM_BUILD_ROOT/etc/pam.d/
274 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
275 install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
276 %if %{build6x}
277 install -m644 contrib/redhat/sshd.pam.old $RPM_BUILD_ROOT/etc/pam.d/sshd
278 %else
279 install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
280 %endif
281 install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
282
283 %if ! %{no_x11_askpass}
284 install x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
285 ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
286 %endif
287
288 %if ! %{no_gnome_askpass}
289 install contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
290 %endif
291
292 %if ! %{scard}
293          rm -f $RPM_BUILD_ROOT/usr/share/openssh/Ssh.bin
294 %endif
295
296 %if ! %{no_gnome_askpass}
297 install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
298 install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
299 install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
300 %endif
301
302 perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
303
304 %clean
305 rm -rf $RPM_BUILD_ROOT
306
307 %triggerun server -- ssh-server
308 if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
309         touch /var/run/sshd.restart
310 fi
311
312 %triggerun server -- openssh-server < 2.5.0p1
313 # Count the number of HostKey and HostDsaKey statements we have.
314 gawk    'BEGIN {IGNORECASE=1}
315          /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
316          END {exit sawhostkey}' /etc/ssh/sshd_config
317 # And if we only found one, we know the client was relying on the old default
318 # behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
319 # specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
320 # one nullifies the default, which would have loaded both.
321 if [ $? -eq 1 ] ; then
322         echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
323         echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
324 fi
325
326 %triggerpostun server -- ssh-server
327 if [ "$1" != 0 ] ; then
328         /sbin/chkconfig --add sshd
329         if test -f /var/run/sshd.restart ; then
330                 rm -f /var/run/sshd.restart
331                 /sbin/service sshd start > /dev/null 2>&1 || :
332         fi
333 fi
334
335 %pre server
336 %{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
337 %{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
338         -g sshd -M -r sshd 2>/dev/null || :
339
340 %post server
341 /sbin/chkconfig --add sshd
342
343 %postun server
344 /sbin/service sshd condrestart > /dev/null 2>&1 || :
345
346 %preun server
347 if [ "$1" = 0 ]
348 then
349         /sbin/service sshd stop > /dev/null 2>&1 || :
350         /sbin/chkconfig --del sshd
351 fi
352
353 %files
354 %defattr(-,root,root)
355 %doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* PROTOCOL* TODO
356 %attr(0755,root,root) %{_bindir}/scp
357 %attr(0644,root,root) %{_mandir}/man1/scp.1*
358 %attr(0755,root,root) %dir %{_sysconfdir}/ssh
359 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
360 %if ! %{rescue}
361 %attr(0755,root,root) %{_bindir}/ssh-keygen
362 %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
363 %attr(0755,root,root) %dir %{_libexecdir}/openssh
364 %attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
365 %attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
366 %attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
367 %attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
368 %endif
369 %if %{scard}
370 %attr(0755,root,root) %dir %{_datadir}/openssh
371 %attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
372 %endif
373
374 %files clients
375 %defattr(-,root,root)
376 %attr(0755,root,root) %{_bindir}/ssh
377 %attr(0644,root,root) %{_mandir}/man1/ssh.1*
378 %attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
379 %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
380 %if ! %{rescue}
381 %attr(2755,root,nobody) %{_bindir}/ssh-agent
382 %attr(0755,root,root) %{_bindir}/ssh-add
383 %attr(0755,root,root) %{_bindir}/ssh-keyscan
384 %attr(0755,root,root) %{_bindir}/sftp
385 %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
386 %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
387 %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
388 %attr(0644,root,root) %{_mandir}/man1/sftp.1*
389 %endif
390
391 %if ! %{rescue}
392 %files server
393 %defattr(-,root,root)
394 %dir %attr(0111,root,root) %{_var}/empty/sshd
395 %attr(0755,root,root) %{_sbindir}/sshd
396 %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
397 %attr(0644,root,root) %{_mandir}/man8/sshd.8*
398 %attr(0644,root,root) %{_mandir}/man5/moduli.5*
399 %attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
400 %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
401 %attr(0755,root,root) %dir %{_sysconfdir}/ssh
402 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
403 %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
404 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
405 %endif
406
407 %if ! %{no_x11_askpass}
408 %files askpass
409 %defattr(-,root,root)
410 %doc x11-ssh-askpass-%{aversion}/README
411 %doc x11-ssh-askpass-%{aversion}/ChangeLog
412 %doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
413 %{_libexecdir}/openssh/ssh-askpass
414 %attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
415 %endif
416
417 %if ! %{no_gnome_askpass}
418 %files askpass-gnome
419 %defattr(-,root,root)
420 %attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
421 %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
422 %endif
423
424 %changelog
425 * Sat Feb 10 2018 Darren Tucker <dtucker@dtucker.net>
426 - Update openssl-devel dependency to match current requirements.
427 - Handle Fedora >=6 openssl 1.0 compat libs.
428 - Remove SSH1 from description.
429 - Don't strip binaries at build time so that debuginfo package can be
430   created.
431
432 * Sun Nov 16 2014 Nico Kadel-Garcia <nakdel@gmail.com>
433 - Add '--mandir' and '--with-mantype' for RHEL 5 compatibility
434 - Add 'dist' option to 'ver' so package names reflect OS at build time
435 - Always include x11-ssh-askpass tarball in SRPM
436 - Add openssh-x11-aspass BuildRequires for libXT-devel, imake, gtk2-devel
437 - Discard 'K5DIR' reporting, not usable inside 'mock' for RHEL 5 compatibility
438 - Discard obsolete '--with-rsh' configure option
439 - Update openssl-devel dependency to 0.9.8f, as found in autoconf
440
441 * Wed Jul 14 2010 Tim Rice <tim@multitalents.net>
442 - test for skip_x11_askpass (line 77) should have been for no_x11_askpass
443
444 * Mon Jun 2 2003 Damien Miller <djm@mindrot.org>
445 - Remove noip6 option. This may be controlled at run-time in client config
446   file using new AddressFamily directive
447
448 * Mon May 12 2003 Damien Miller <djm@mindrot.org>
449 - Don't install profile.d scripts when not building with GNOME/GTK askpass
450   (patch from bet@rahul.net)
451
452 * Tue Oct 01 2002 Damien Miller <djm@mindrot.org>
453 - Install ssh-agent setgid nobody to prevent ptrace() key theft attacks
454
455 * Mon Sep 30 2002 Damien Miller <djm@mindrot.org>
456 - Use contrib/ Makefile for building askpass programs
457
458 * Fri Jun 21 2002 Damien Miller <djm@mindrot.org>
459 - Merge in spec changes from seba@iq.pl (Sebastian Pachuta)
460 - Add new {ssh,sshd}_config.5 manpages
461 - Add new ssh-keysign program and remove setuid from ssh client
462
463 * Fri May 10 2002 Damien Miller <djm@mindrot.org>
464 - Merge in spec changes from RedHat, reorgansie a little
465 - Add Privsep user, group and directory
466
467 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-2
468 - bump and grind (through the build system)
469
470 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-1
471 - require sharutils for building (mindrot #137)
472 - require db1-devel only when building for 6.x (#55105), which probably won't
473   work anyway (3.1 requires OpenSSL 0.9.6 to build), but what the heck
474 - require pam-devel by file (not by package name) again
475 - add Markus's patch to compile with OpenSSL 0.9.5a (from
476   http://bugzilla.mindrot.org/show_bug.cgi?id=141) and apply it if we're
477   building for 6.x
478
479 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-0
480 - update to 3.1p1
481
482 * Tue Mar  5 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020305
483 - update to SNAP-20020305
484 - drop debug patch, fixed upstream
485
486 * Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020220
487 - update to SNAP-20020220 for testing purposes (you've been warned, if there's
488   anything to be warned about, gss patches won't apply, I don't mind)
489
490 * Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-3
491 - add patches from Simon Wilkinson and Nicolas Williams for GSSAPI key
492   exchange, authentication, and named key support
493
494 * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-2
495 - remove dependency on db1-devel, which has just been swallowed up whole
496   by gnome-libs-devel
497
498 * Sat Dec 29 2001 Nalin Dahyabhai <nalin@redhat.com>
499 - adjust build dependencies so that build6x actually works right (fix
500   from Hugo van der Kooij)
501
502 * Tue Dec  4 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-1
503 - update to 3.0.2p1
504
505 * Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.1p1-1
506 - update to 3.0.1p1
507
508 * Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
509 - update to current CVS (not for use in distribution)
510
511 * Thu Nov  8 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0p1-1
512 - merge some of Damien Miller <djm@mindrot.org> changes from the upstream
513   3.0p1 spec file and init script
514
515 * Wed Nov  7 2001 Nalin Dahyabhai <nalin@redhat.com>
516 - update to 3.0p1
517 - update to x11-ssh-askpass 1.2.4.1
518 - change build dependency on a file from pam-devel to the pam-devel package
519 - replace primes with moduli
520
521 * Thu Sep 27 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-9
522 - incorporate fix from Markus Friedl's advisory for IP-based authorization bugs
523
524 * Thu Sep 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.9p2-8
525 - Merge changes to rescue build from current sysadmin survival cd
526
527 * Thu Sep  6 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-7
528 - fix scp's server's reporting of file sizes, and build with the proper
529   preprocessor define to get large-file capable open(), stat(), etc.
530   (sftp has been doing this correctly all along) (#51827)
531 - configure without --with-ipv4-default on RHL 7.x and newer (#45987,#52247)
532 - pull cvs patch to fix support for /etc/nologin for non-PAM logins (#47298)
533 - mark profile.d scriptlets as config files (#42337)
534 - refer to Jason Stone's mail for zsh workaround for exit-hanging quasi-bug
535 - change a couple of log() statements to debug() statements (#50751)
536 - pull cvs patch to add -t flag to sshd (#28611)
537 - clear fd_sets correctly (one bit per FD, not one byte per FD) (#43221)
538
539 * Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-6
540 - add db1-devel as a BuildPrerequisite (noted by Hans Ecke)
541
542 * Thu Aug 16 2001 Nalin Dahyabhai <nalin@redhat.com>
543 - pull cvs patch to fix remote port forwarding with protocol 2
544
545 * Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com>
546 - pull cvs patch to add session initialization to no-pty sessions
547 - pull cvs patch to not cut off challengeresponse auth needlessly
548 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
549   it by default on a system that doesn't have X installed (#49263)
550
551 * Wed Aug  8 2001 Nalin Dahyabhai <nalin@redhat.com>
552 - don't apply patches to code we don't intend to build (spotted by Matt Galgoci)
553
554 * Mon Aug  6 2001 Nalin Dahyabhai <nalin@redhat.com>
555 - pass OPTIONS correctly to initlog (#50151)
556
557 * Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
558 - switch to x11-ssh-askpass 1.2.2
559
560 * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
561 - rebuild in new environment
562
563 * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
564 - disable the gssapi patch
565
566 * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
567 - update to 2.9p2
568 - refresh to a new version of the gssapi patch
569
570 * Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
571 - change Copyright: BSD to License: BSD
572 - add Markus Friedl's unverified patch for the cookie file deletion problem
573   so that we can verify it
574 - drop patch to check if xauth is present (was folded into cookie patch)
575 - don't apply gssapi patches for the errata candidate
576 - clear supplemental groups list at startup
577
578 * Fri May 25 2001 Nalin Dahyabhai <nalin@redhat.com>
579 - fix an error parsing the new default sshd_config
580 - add a fix from Markus Friedl (via openssh-unix-dev) for ssh-keygen not
581   dealing with comments right
582
583 * Thu May 24 2001 Nalin Dahyabhai <nalin@redhat.com>
584 - add in Simon Wilkinson's GSSAPI patch to give it some testing in-house,
585   to be removed before the next beta cycle because it's a big departure
586   from the upstream version
587
588 * Thu May  3 2001 Nalin Dahyabhai <nalin@redhat.com>
589 - finish marking strings in the init script for translation
590 - modify init script to source /etc/sysconfig/sshd and pass $OPTIONS to sshd
591   at startup (change merged from openssh.com init script, originally by
592   Pekka Savola)
593 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
594   it by default on a system that doesn't have X installed
595
596 * Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com>
597 - update to 2.9
598 - drop various patches that came from or went upstream or to or from CVS
599
600 * Wed Apr 18 2001 Nalin Dahyabhai <nalin@redhat.com>
601 - only require initscripts 5.00 on 6.2 (reported by Peter Bieringer)
602
603 * Sun Apr  8 2001 Preston Brown <pbrown@redhat.com>
604 - remove explicit openssl requirement, fixes builddistro issue
605 - make initscript stop() function wait until sshd really dead to avoid
606   races in condrestart
607
608 * Mon Apr  2 2001 Nalin Dahyabhai <nalin@redhat.com>
609 - mention that challengereponse supports PAM, so disabling password doesn't
610   limit users to pubkey and rsa auth (#34378)
611 - bypass the daemon() function in the init script and call initlog directly,
612   because daemon() won't start a daemon it detects is already running (like
613   open connections)
614 - require the version of openssl we had when we were built
615
616 * Fri Mar 23 2001 Nalin Dahyabhai <nalin@redhat.com>
617 - make do_pam_setcred() smart enough to know when to establish creds and
618   when to reinitialize them
619 - add in a couple of other fixes from Damien for inclusion in the errata
620
621 * Thu Mar 22 2001 Nalin Dahyabhai <nalin@redhat.com>
622 - update to 2.5.2p2
623 - call setcred() again after initgroups, because the "creds" could actually
624   be group memberships
625
626 * Tue Mar 20 2001 Nalin Dahyabhai <nalin@redhat.com>
627 - update to 2.5.2p1 (includes endianness fixes in the rijndael implementation)
628 - don't enable challenge-response by default until we find a way to not
629   have too many userauth requests (we may make up to six pubkey and up to
630   three password attempts as it is)
631 - remove build dependency on rsh to match openssh.com's packages more closely
632
633 * Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
634 - remove dependency on openssl -- would need to be too precise
635
636 * Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
637 - rebuild in new environment
638
639 * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
640 - Revert the patch to move pam_open_session.
641 - Init script and spec file changes from Pekka Savola. (#28750)
642 - Patch sftp to recognize '-o protocol' arguments. (#29540)
643
644 * Thu Feb 22 2001 Nalin Dahyabhai <nalin@redhat.com>
645 - Chuck the closing patch.
646 - Add a trigger to add host keys for protocol 2 to the config file, now that
647   configuration file syntax requires us to specify it with HostKey if we
648   specify any other HostKey values, which we do.
649
650 * Tue Feb 20 2001 Nalin Dahyabhai <nalin@redhat.com>
651 - Redo patch to move pam_open_session after the server setuid()s to the user.
652 - Rework the nopam patch to use be picked up by autoconf.
653
654 * Mon Feb 19 2001 Nalin Dahyabhai <nalin@redhat.com>
655 - Update for 2.5.1p1.
656 - Add init script mods from Pekka Savola.
657 - Tweak the init script to match the CVS contrib script more closely.
658 - Redo patch to ssh-add to try to adding both identity and id_dsa to also try
659   adding id_rsa.
660
661 * Fri Feb 16 2001 Nalin Dahyabhai <nalin@redhat.com>
662 - Update for 2.5.0p1.
663 - Use $RPM_OPT_FLAGS instead of -O when building gnome-ssh-askpass
664 - Resync with parts of Damien Miller's openssh.spec from CVS, including
665   update of x11 askpass to 1.2.0.
666 - Only require openssl (don't prereq) because we generate keys in the init
667   script now.
668
669 * Tue Feb 13 2001 Nalin Dahyabhai <nalin@redhat.com>
670 - Don't open a PAM session until we've forked and become the user (#25690).
671 - Apply Andrew Bartlett's patch for letting pam_authenticate() know which
672   host the user is attempting a login from.
673 - Resync with parts of Damien Miller's openssh.spec from CVS.
674 - Don't expose KbdInt responses in debug messages (from CVS).
675 - Detect and handle errors in rsa_{public,private}_decrypt (from CVS).
676
677 * Wed Feb  7 2001 Trond Eivind Glomsrxd <teg@redhat.com>
678 - i18n-tweak to initscript.
679
680 * Tue Jan 23 2001 Nalin Dahyabhai <nalin@redhat.com>
681 - More gettextizing.
682 - Close all files after going into daemon mode (needs more testing).
683 - Extract patch from CVS to handle auth banners (in the client).
684 - Extract patch from CVS to handle compat weirdness.
685
686 * Fri Jan 19 2001 Nalin Dahyabhai <nalin@redhat.com>
687 - Finish with the gettextizing.
688
689 * Thu Jan 18 2001 Nalin Dahyabhai <nalin@redhat.com>
690 - Fix a bug in auth2-pam.c (#23877)
691 - Gettextize the init script.
692
693 * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
694 - Incorporate a switch for using PAM configs for 6.x, just in case.
695
696 * Tue Dec  5 2000 Nalin Dahyabhai <nalin@redhat.com>
697 - Incorporate Bero's changes for a build specifically for rescue CDs.
698
699 * Wed Nov 29 2000 Nalin Dahyabhai <nalin@redhat.com>
700 - Don't treat pam_setcred() failure as fatal unless pam_authenticate() has
701   succeeded, to allow public-key authentication after a failure with "none"
702   authentication.  (#21268)
703
704 * Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
705 - Update to x11-askpass 1.1.1. (#21301)
706 - Don't second-guess fixpaths, which causes paths to get fixed twice. (#21290)
707
708 * Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
709 - Merge multiple PAM text messages into subsequent prompts when possible when
710   doing keyboard-interactive authentication.
711
712 * Sun Nov 26 2000 Nalin Dahyabhai <nalin@redhat.com>
713 - Disable the built-in MD5 password support.  We're using PAM.
714 - Take a crack at doing keyboard-interactive authentication with PAM, and
715   enable use of it in the default client configuration so that the client
716   will try it when the server disallows password authentication.
717 - Build with debugging flags.  Build root policies strip all binaries anyway.
718
719 * Tue Nov 21 2000 Nalin Dahyabhai <nalin@redhat.com>
720 - Use DESTDIR instead of %%makeinstall.
721 - Remove /usr/X11R6/bin from the path-fixing patch.
722
723 * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
724 - Add the primes file from the latest snapshot to the main package (#20884).
725 - Add the dev package to the prereq list (#19984).
726 - Remove the default path and mimic login's behavior in the server itself.
727
728 * Fri Nov 17 2000 Nalin Dahyabhai <nalin@redhat.com>
729 - Resync with conditional options in Damien Miller's .spec file for an errata.
730 - Change libexecdir from %%{_libexecdir}/ssh to %%{_libexecdir}/openssh.
731
732 * Tue Nov  7 2000 Nalin Dahyabhai <nalin@redhat.com>
733 - Update to OpenSSH 2.3.0p1.
734 - Update to x11-askpass 1.1.0.
735 - Enable keyboard-interactive authentication.
736
737 * Mon Oct 30 2000 Nalin Dahyabhai <nalin@redhat.com>
738 - Update to ssh-askpass-x11 1.0.3.
739 - Change authentication related messages to be private (#19966).
740
741 * Tue Oct 10 2000 Nalin Dahyabhai <nalin@redhat.com>
742 - Patch ssh-keygen to be able to list signatures for DSA public key files
743   it generates.
744
745 * Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
746 - Add BuildRequires on /usr/include/security/pam_appl.h to be sure we always
747   build PAM authentication in.
748 - Try setting SSH_ASKPASS if gnome-ssh-askpass is installed.
749 - Clean out no-longer-used patches.
750 - Patch ssh-add to try to add both identity and id_dsa, and to error only
751   when neither exists.
752
753 * Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
754 - Update x11-askpass to 1.0.2. (#17835)
755 - Add BuildRequiress for /bin/login and /usr/bin/rsh so that configure will
756   always find them in the right place. (#17909)
757 - Set the default path to be the same as the one supplied by /bin/login, but
758   add /usr/X11R6/bin. (#17909)
759 - Try to handle obsoletion of ssh-server more cleanly.  Package names
760   are different, but init script name isn't. (#17865)
761
762 * Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
763 - Update to 2.2.0p1. (#17835)
764 - Tweak the init script to allow proper restarting. (#18023)
765
766 * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
767 - Update to 20000823 snapshot.
768 - Change subpackage requirements from %%{version} to %%{version}-%%{release}
769 - Back out the pipe patch.
770
771 * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
772 - Update to 2.1.1p4, which includes fixes for config file parsing problems.
773 - Move the init script back.
774 - Add Damien's quick fix for wackiness.
775
776 * Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
777 - Update to 2.1.1p3, which includes fixes for X11 forwarding and strtok().
778
779 * Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
780 - Move condrestart to server postun.
781 - Move key generation to init script.
782 - Actually use the right patch for moving the key generation to the init script.
783 - Clean up the init script a bit.
784
785 * Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
786 - Fix X11 forwarding, from mail post by Chan Shih-Ping Richard.
787
788 * Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
789 - Update to 2.1.1p2.
790 - Use of strtok() considered harmful.
791
792 * Sat Jul  1 2000 Nalin Dahyabhai <nalin@redhat.com>
793 - Get the build root out of the man pages.
794
795 * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
796 - Add and use condrestart support in the init script.
797 - Add newer initscripts as a prereq.
798
799 * Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
800 - Build in new environment (release 2)
801 - Move -clients subpackage to Applications/Internet group
802
803 * Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
804 - Update to 2.2.1p1
805
806 * Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
807 - Patch to build with neither RSA nor RSAref.
808 - Miscellaneous FHS-compliance tweaks.
809 - Fix for possibly-compressed man pages.
810
811 * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
812 - Updated for new location
813 - Updated for new gnome-ssh-askpass build
814
815 * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
816 - Added Jim Knoble's <jmknoble@pobox.com> askpass
817
818 * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
819 - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
820
821 * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
822 - Added 'Obsoletes' directives
823
824 * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
825 - Use make install
826 - Subpackages
827
828 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
829 - Added links for slogin
830 - Fixed perms on manpages
831
832 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
833 - Renamed init script
834
835 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
836 - Back to old binary names
837
838 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
839 - Use autoconf
840 - New binary names
841
842 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
843 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.