]> CyberLeo.Net >> Repos - CDN/portage-cdn.git/blob - sys-fs/cryptofs-fuse/cryptofs-fuse-0.6.0.ebuild
media-video/mplayer: add ASS patch
[CDN/portage-cdn.git] / sys-fs / cryptofs-fuse / cryptofs-fuse-0.6.0.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 inherit eutils
7
8 MY_PN="${PN/-fuse/}"
9 MY_P="${MY_PN}-${PV}"
10
11 DESCRIPTION="CryptoFS Fuse"
12 HOMEPAGE="http://reboot78.re.funpic.de/${MY_PN}/"
13 SRC_URI="http://reboot78.re.funpic.de/${MY_PN}/${MY_P}.tar.bz2
14         http://alba.cyberleo.net/portage/mirror/${MY_PN}/${MY_P}.tar.bz2"
15
16 LICENSE="GPL"
17 SLOT="0"
18 KEYWORDS="~x86 ~amd64"
19 IUSE="-pinentry"
20
21 DEPEND=">=dev-libs/glib-2.6
22         >=dev-libs/libgcrypt-1.1.44
23         >=sys-fs/fuse-2.8.0
24         pinentry? ( app-crypt/pinentry )"
25 RDEPEND="${DEPEND}"
26
27 S="${WORKDIR}/${MY_P}"
28
29 src_configure() {
30         econf $(use_with pinentry) || die "configure failed"
31 }
32
33 src_install() {
34         emake DESTDIR="${D}" install
35         dodoc AUTHORS NEWS README cryptofs.conf
36 }