]> CyberLeo.Net >> Repos - FreeBSD/releng/10.2.git/blob - contrib/ldns/packaging/fedora/ldns.spec
- Copy stable/10@285827 to releng/10.2 in preparation for 10.2-RC1
[FreeBSD/releng/10.2.git] / contrib / ldns / packaging / fedora / ldns.spec
1 %{?!with_python:      %global with_python      1}\r
2 \r
3 %if %{with_python}\r
4 %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}\r
5 %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}\r
6 %endif\r
7 \r
8 Summary: Lowlevel DNS(SEC) library with API\r
9 Name: ldns\r
10 Version: 1.6.13\r
11 Release: 1%{?dist}\r
12 License: BSD\r
13 Url: http://www.nlnetlabs.nl/%{name}/\r
14 Source: http://www.nlnetlabs.nl/downloads/%{%name}/%{name}-%{version}.tar.gz\r
15 Group: System Environment/Libraries\r
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)\r
17 BuildRequires: perl, libpcap-devel, openssl-devel , gcc-c++, doxygen,\r
18 # Only needed for builds from svn snapshot\r
19 # BuildRequires: libtool, autoconf, automake\r
20 \r
21 %if %{with_python}\r
22 BuildRequires:  python-devel, swig\r
23 %endif\r
24 \r
25 %description\r
26 ldns is a library with the aim to simplify DNS programing in C. All\r
27 lowlevel DNS/DNSSEC operations are supported. We also define a higher\r
28 level API which allows a programmer to (for instance) create or sign\r
29 packets.\r
30 \r
31 %package devel\r
32 Summary: Development package that includes the ldns header files\r
33 Group: Development/Libraries\r
34 Requires: %{name} = %{version}-%{release}\r
35 \r
36 %description devel\r
37 The devel package contains the ldns library and the include files\r
38 \r
39 %if %{with_python}\r
40 %package python\r
41 Summary: Python extensions for ldns\r
42 Group: Applications/System\r
43 Requires: %{name} = %{version}-%{release}\r
44 \r
45 %description python\r
46 Python extensions for ldns\r
47 %endif\r
48 \r
49 %prep\r
50 %setup -q \r
51 # To built svn snapshots\r
52 # rm config.guess config.sub ltmain.sh\r
53 # aclocal\r
54 # libtoolize -c \r
55 # autoreconf \r
56 \r
57 %build\r
58 %configure --disable-rpath --disable-static --with-sha2 --disable-gost \\r
59 %if %{with_python}\r
60  --with-pyldns\r
61 %endif\r
62 \r
63 (cd drill ; %configure --disable-rpath --disable-static --with-sha2 --disable-gost --with-ldns=%{buildroot}/lib/ )\r
64 (cd examples ; %configure --disable-rpath --disable-static --with-sha2 --disable-gost --with-ldns=%{buildroot}/lib/ )\r
65 \r
66 make %{?_smp_mflags} \r
67 ( cd drill ; make %{?_smp_mflags} )\r
68 ( cd examples ; make %{?_smp_mflags} )\r
69 make %{?_smp_mflags} doc\r
70 \r
71 %install\r
72 rm -rf %{buildroot}\r
73 \r
74 make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install \r
75 make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc\r
76 \r
77 # don't install another set of man pages from doc/\r
78 rm -rf doc/man/\r
79 \r
80 # don't package building script for install-doc in doc section\r
81 rm doc/doxyparse.pl\r
82 \r
83 # remove .la files\r
84 rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitearch}/*.la\r
85 (cd drill ; make DESTDIR=%{buildroot} install)\r
86 (cd examples; make DESTDIR=%{buildroot} install)\r
87 \r
88 %clean\r
89 rm -rf %{buildroot}\r
90 \r
91 %files \r
92 %defattr(-,root,root)\r
93 %{_libdir}/libldns*so.*\r
94 %{_bindir}/drill\r
95 %{_bindir}/ldnsd\r
96 %{_bindir}/ldns-chaos\r
97 %{_bindir}/ldns-compare-zones\r
98 %{_bindir}/ldns-[d-z]*\r
99 %doc README LICENSE\r
100 %{_mandir}/*/*\r
101 \r
102 %files devel\r
103 %defattr(-,root,root,-)\r
104 %{_libdir}/libldns*so\r
105 %{_bindir}/ldns-config\r
106 %dir %{_includedir}/ldns\r
107 %{_includedir}/ldns/*.h\r
108 %doc doc Changelog README\r
109 \r
110 %if %{with_python}\r
111 %files python\r
112 %defattr(-,root,root)\r
113 %{python_sitearch}/*\r
114 %endif\r
115 \r
116 %post -p /sbin/ldconfig\r
117 \r
118 %postun -p /sbin/ldconfig\r
119 \r
120 %changelog\r
121 * Thu Sep 22 2011 Paul Wouters <paul@xelerance.com> - 1.6.11-1\r
122 - Updated to 1.6.11\r
123 - Cleanup spec for\r
124 - Python goes into sitearch, not sitelib\r
125 \r
126 * Wed Jun 08 2011 Paul Wouters <paul@xelerance.com> - 1.6.10-1\r
127 - Updated to 1.6.10\r
128 - commented out build dependancies for svn snapshots\r
129 \r
130 * Sun Mar 27 2011 Paul Wouters <paul@xelerance.com> - 1.6.9-1\r
131 - Updated to 1.6.9\r
132 \r
133 * Mon Jan 24 2011 Paul Wouters <paul@xelerance.com> - 1.6.8-1\r
134 - Updated to 1.6.8\r
135 \r
136 * Thu Aug 26 2010 Paul Wouters <paul@xelerance.com> - 1.6.6-1\r
137 - Upgraded to 1.6.6\r
138 \r
139 * Mon Apr 26 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-4\r
140 - Disable a debug line that was added to find the LOC issue that causes\r
141   unexpected output for automated tools using ldns-read-zone\r
142 \r
143 * Thu Feb 11 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-3\r
144 - Applied fix svn 3186 for LOC record parsing\r
145 \r
146 * Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2\r
147 - libtool on EL-5 does not take --install as argument\r
148 \r
149 * Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1\r
150 - Upgraded to 1.6.4\r
151 - Added ldns-python sub package\r
152 - Patch for installing ldns-python files\r
153 - Patch for rpath in ldns-python\r
154 \r
155 * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2\r
156 - Bump version, sources file was not updated.\r
157 \r
158 * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1\r
159 -Updated to 1.6.1\r
160 \r
161 * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1\r
162 - Updated to 1.6.0\r
163 \r
164 * Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-2\r
165 - Memory management bug when generating a sha256 key, see:\r
166   https://bugzilla.redhat.com/show_bug.cgi?id=493953\r
167 \r
168 * Fri Feb 13 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1\r
169 - Upgrade to 1.5.1 (1.5.0 was a dud release)\r
170 \r
171 * Sun Nov  9 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-2\r
172 - libldns.so was missing in files section.\r
173 \r
174 * Sun Nov  9 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1\r
175 - Updated to 1.4.0\r
176 - enable SHA2 functionality\r
177 \r
178 * Mon Jun 30 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1\r
179 - Updated to latest release\r
180 \r
181 * Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1\r
182 - Upgraded to 1.2.2.\r
183 \r
184 * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4\r
185 - Commented out 1.1.0 make targets, put make 1.0.1 targets.\r
186 \r
187 * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3\r
188 - Fixed changelog typo in date\r
189 - Rebuild requested for PT_GNU_HASH support from gcc\r
190 - Did not upgrade to 1.1.0 due to compile issues on x86_64\r
191 \r
192 * Fri Jan  6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1\r
193 - Upgraded to 1.0.1. Removed temporary clean hack from spec file.\r
194 \r
195 * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8\r
196 - Cannot use make clean because there are no Makefiles. Use hardcoded rm.\r
197 \r
198 * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7\r
199 - Patched 'make clean' target to get rid of object files shipped with 1.0.0\r
200 \r
201 * Sun Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6\r
202 - added a make clean for 2.3.3 since .o files were left behind upstream,\r
203   causing failure on ppc platform\r
204 \r
205 * Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5\r
206 - minor cleanups\r
207 \r
208 * Wed Oct  5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205\r
209 - reworked for svn version\r
210 \r
211 * Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70\r
212 - Initial version\r