]> CyberLeo.Net >> Repos - FreeBSD/releng/10.3.git/blob - crypto/openssh/contrib/redhat/openssh.spec
- Copy stable/10@296371 to releng/10.3 in preparation for 10.3-RC1
[FreeBSD/releng/10.3.git] / crypto / openssh / contrib / redhat / openssh.spec
1 %define ver 7.1p2
2 %define rel 1
3
4 # OpenSSH privilege separation requires a user & group ID
5 %define sshd_uid    74
6 %define sshd_gid    74
7
8 # Version of ssh-askpass
9 %define aversion 1.2.4.1
10
11 # Do we want to disable building of x11-askpass? (1=yes 0=no)
12 %define no_x11_askpass 0
13
14 # Do we want to disable building of gnome-askpass? (1=yes 0=no)
15 %define no_gnome_askpass 0
16
17 # Do we want to link against a static libcrypto? (1=yes 0=no)
18 %define static_libcrypto 0
19
20 # Do we want smartcard support (1=yes 0=no)
21 %define scard 0
22
23 # Use GTK2 instead of GNOME in gnome-ssh-askpass
24 %define gtk2 1
25
26 # Is this build for RHL 6.x?
27 %define build6x 0
28
29 # Do we want kerberos5 support (1=yes 0=no)
30 %define kerberos5 1
31
32 # Reserve options to override askpass settings with:
33 # rpm -ba|--rebuild --define 'skip_xxx 1'
34 %{?skip_x11_askpass:%define no_x11_askpass 1}
35 %{?skip_gnome_askpass:%define no_gnome_askpass 1}
36
37 # Add option to build without GTK2 for older platforms with only GTK+.
38 # RedHat <= 7.2 and Red Hat Advanced Server 2.1 are examples.
39 # rpm -ba|--rebuild --define 'no_gtk2 1'
40 %{?no_gtk2:%define gtk2 0}
41
42 # Is this a build for RHL 6.x or earlier?
43 %{?build_6x:%define build6x 1}
44
45 # If this is RHL 6.x, the default configuration has sysconfdir in /usr/etc.
46 %if %{build6x}
47 %define _sysconfdir /etc
48 %endif
49
50 # Options for static OpenSSL link:
51 # rpm -ba|--rebuild --define "static_openssl 1"
52 %{?static_openssl:%define static_libcrypto 1}
53
54 # Options for Smartcard support: (needs libsectok and openssl-engine)
55 # rpm -ba|--rebuild --define "smartcard 1"
56 %{?smartcard:%define scard 1}
57
58 # Is this a build for the rescue CD (without PAM, with MD5)? (1=yes 0=no)
59 %define rescue 0
60 %{?build_rescue:%define rescue 1}
61
62 # Turn off some stuff for resuce builds
63 %if %{rescue}
64 %define kerberos5 0
65 %endif
66
67 Summary: The OpenSSH implementation of SSH protocol versions 1 and 2.
68 Name: openssh
69 Version: %{ver}
70 %if %{rescue}
71 Release: %{rel}rescue
72 %else
73 Release: %{rel}
74 %endif
75 URL: http://www.openssh.com/portable.html
76 Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
77 %if ! %{no_x11_askpass}
78 Source1: http://www.jmknoble.net/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
79 %endif
80 License: BSD
81 Group: Applications/Internet
82 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
83 Obsoletes: ssh
84 %if %{build6x}
85 PreReq: initscripts >= 5.00
86 %else
87 Requires: initscripts >= 5.20
88 %endif
89 BuildRequires: perl, openssl-devel
90 BuildRequires: /bin/login
91 %if ! %{build6x}
92 BuildPreReq: glibc-devel, pam
93 %else
94 BuildRequires: /usr/include/security/pam_appl.h
95 %endif
96 %if ! %{no_x11_askpass}
97 BuildRequires: /usr/include/X11/Xlib.h
98 %endif
99 %if ! %{no_gnome_askpass}
100 BuildRequires: pkgconfig
101 %endif
102 %if %{kerberos5}
103 BuildRequires: krb5-devel
104 BuildRequires: krb5-libs
105 %endif
106
107 %package clients
108 Summary: OpenSSH clients.
109 Requires: openssh = %{version}-%{release}
110 Group: Applications/Internet
111 Obsoletes: ssh-clients
112
113 %package server
114 Summary: The OpenSSH server daemon.
115 Group: System Environment/Daemons
116 Obsoletes: ssh-server
117 Requires: openssh = %{version}-%{release}, chkconfig >= 0.9
118 %if ! %{build6x}
119 Requires: /etc/pam.d/system-auth
120 %endif
121
122 %package askpass
123 Summary: A passphrase dialog for OpenSSH and X.
124 Group: Applications/Internet
125 Requires: openssh = %{version}-%{release}
126 Obsoletes: ssh-extras
127
128 %package askpass-gnome
129 Summary: A passphrase dialog for OpenSSH, X, and GNOME.
130 Group: Applications/Internet
131 Requires: openssh = %{version}-%{release}
132 Obsoletes: ssh-extras
133
134 %description
135 SSH (Secure SHell) is a program for logging into and executing
136 commands on a remote machine. SSH is intended to replace rlogin and
137 rsh, and to provide secure encrypted communications between two
138 untrusted hosts over an insecure network. X11 connections and
139 arbitrary TCP/IP ports can also be forwarded over the secure channel.
140
141 OpenSSH is OpenBSD's version of the last free version of SSH, bringing
142 it up to date in terms of security and features, as well as removing
143 all patented algorithms to separate libraries.
144
145 This package includes the core files necessary for both the OpenSSH
146 client and server. To make this package useful, you should also
147 install openssh-clients, openssh-server, or both.
148
149 %description clients
150 OpenSSH is a free version of SSH (Secure SHell), a program for logging
151 into and executing commands on a remote machine. This package includes
152 the clients necessary to make encrypted connections to SSH servers.
153 You'll also need to install the openssh package on OpenSSH clients.
154
155 %description server
156 OpenSSH is a free version of SSH (Secure SHell), a program for logging
157 into and executing commands on a remote machine. This package contains
158 the secure shell daemon (sshd). The sshd daemon allows SSH clients to
159 securely connect to your SSH server. You also need to have the openssh
160 package installed.
161
162 %description askpass
163 OpenSSH is a free version of SSH (Secure SHell), a program for logging
164 into and executing commands on a remote machine. This package contains
165 an X11 passphrase dialog for OpenSSH.
166
167 %description askpass-gnome
168 OpenSSH is a free version of SSH (Secure SHell), a program for logging
169 into and executing commands on a remote machine. This package contains
170 an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
171 environment.
172
173 %prep
174
175 %if ! %{no_x11_askpass}
176 %setup -q -a 1
177 %else
178 %setup -q
179 %endif
180
181 %build
182 %if %{rescue}
183 CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
184 %endif
185
186 %if %{kerberos5}
187 K5DIR=`rpm -ql krb5-devel | grep include/krb5.h | sed 's,\/include\/krb5.h,,'`
188 echo K5DIR=$K5DIR
189 %endif
190
191 %configure \
192         --sysconfdir=%{_sysconfdir}/ssh \
193         --libexecdir=%{_libexecdir}/openssh \
194         --datadir=%{_datadir}/openssh \
195         --with-rsh=%{_bindir}/rsh \
196         --with-default-path=/usr/local/bin:/bin:/usr/bin \
197         --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
198         --with-privsep-path=%{_var}/empty/sshd \
199         --with-md5-passwords \
200 %if %{scard}
201         --with-smartcard \
202 %endif
203 %if %{rescue}
204         --without-pam \
205 %else
206         --with-pam \
207 %endif
208 %if %{kerberos5}
209          --with-kerberos5=$K5DIR \
210 %endif
211
212
213 %if %{static_libcrypto}
214 perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
215 %endif
216
217 make
218
219 %if ! %{no_x11_askpass}
220 pushd x11-ssh-askpass-%{aversion}
221 %configure --libexecdir=%{_libexecdir}/openssh
222 xmkmf -a
223 make
224 popd
225 %endif
226
227 # Define a variable to toggle gnome1/gtk2 building.  This is necessary
228 # because RPM doesn't handle nested %if statements.
229 %if %{gtk2}
230         gtk2=yes
231 %else
232         gtk2=no
233 %endif
234
235 %if ! %{no_gnome_askpass}
236 pushd contrib
237 if [ $gtk2 = yes ] ; then
238         make gnome-ssh-askpass2
239         mv gnome-ssh-askpass2 gnome-ssh-askpass
240 else
241         make gnome-ssh-askpass1
242         mv gnome-ssh-askpass1 gnome-ssh-askpass
243 fi
244 popd
245 %endif
246
247 %install
248 rm -rf $RPM_BUILD_ROOT
249 mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
250 mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
251 mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
252
253 make install DESTDIR=$RPM_BUILD_ROOT
254
255 install -d $RPM_BUILD_ROOT/etc/pam.d/
256 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
257 install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
258 %if %{build6x}
259 install -m644 contrib/redhat/sshd.pam.old $RPM_BUILD_ROOT/etc/pam.d/sshd
260 %else
261 install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
262 %endif
263 install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
264
265 %if ! %{no_x11_askpass}
266 install -s x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
267 ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
268 %endif
269
270 %if ! %{no_gnome_askpass}
271 install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
272 %endif
273
274 %if ! %{scard}
275          rm -f $RPM_BUILD_ROOT/usr/share/openssh/Ssh.bin
276 %endif
277
278 %if ! %{no_gnome_askpass}
279 install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
280 install -m 755 contrib/redhat/gnome-ssh-askpass.csh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
281 install -m 755 contrib/redhat/gnome-ssh-askpass.sh $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
282 %endif
283
284 perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
285
286 %clean
287 rm -rf $RPM_BUILD_ROOT
288
289 %triggerun server -- ssh-server
290 if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
291         touch /var/run/sshd.restart
292 fi
293
294 %triggerun server -- openssh-server < 2.5.0p1
295 # Count the number of HostKey and HostDsaKey statements we have.
296 gawk    'BEGIN {IGNORECASE=1}
297          /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
298          END {exit sawhostkey}' /etc/ssh/sshd_config
299 # And if we only found one, we know the client was relying on the old default
300 # behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
301 # specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
302 # one nullifies the default, which would have loaded both.
303 if [ $? -eq 1 ] ; then
304         echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
305         echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
306 fi
307
308 %triggerpostun server -- ssh-server
309 if [ "$1" != 0 ] ; then
310         /sbin/chkconfig --add sshd
311         if test -f /var/run/sshd.restart ; then
312                 rm -f /var/run/sshd.restart
313                 /sbin/service sshd start > /dev/null 2>&1 || :
314         fi
315 fi
316
317 %pre server
318 %{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
319 %{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
320         -g sshd -M -r sshd 2>/dev/null || :
321
322 %post server
323 /sbin/chkconfig --add sshd
324
325 %postun server
326 /sbin/service sshd condrestart > /dev/null 2>&1 || :
327
328 %preun server
329 if [ "$1" = 0 ]
330 then
331         /sbin/service sshd stop > /dev/null 2>&1 || :
332         /sbin/chkconfig --del sshd
333 fi
334
335 %files
336 %defattr(-,root,root)
337 %doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* PROTOCOL* TODO
338 %attr(0755,root,root) %{_bindir}/scp
339 %attr(0644,root,root) %{_mandir}/man1/scp.1*
340 %attr(0755,root,root) %dir %{_sysconfdir}/ssh
341 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
342 %if ! %{rescue}
343 %attr(0755,root,root) %{_bindir}/ssh-keygen
344 %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
345 %attr(0755,root,root) %dir %{_libexecdir}/openssh
346 %attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
347 %attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
348 %attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
349 %attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
350 %endif
351 %if %{scard}
352 %attr(0755,root,root) %dir %{_datadir}/openssh
353 %attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
354 %endif
355
356 %files clients
357 %defattr(-,root,root)
358 %attr(0755,root,root) %{_bindir}/ssh
359 %attr(0644,root,root) %{_mandir}/man1/ssh.1*
360 %attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
361 %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
362 %attr(-,root,root) %{_bindir}/slogin
363 %attr(-,root,root) %{_mandir}/man1/slogin.1*
364 %if ! %{rescue}
365 %attr(2755,root,nobody) %{_bindir}/ssh-agent
366 %attr(0755,root,root) %{_bindir}/ssh-add
367 %attr(0755,root,root) %{_bindir}/ssh-keyscan
368 %attr(0755,root,root) %{_bindir}/sftp
369 %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
370 %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
371 %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
372 %attr(0644,root,root) %{_mandir}/man1/sftp.1*
373 %endif
374
375 %if ! %{rescue}
376 %files server
377 %defattr(-,root,root)
378 %dir %attr(0111,root,root) %{_var}/empty/sshd
379 %attr(0755,root,root) %{_sbindir}/sshd
380 %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
381 %attr(0644,root,root) %{_mandir}/man8/sshd.8*
382 %attr(0644,root,root) %{_mandir}/man5/moduli.5*
383 %attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
384 %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
385 %attr(0755,root,root) %dir %{_sysconfdir}/ssh
386 %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
387 %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
388 %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
389 %endif
390
391 %if ! %{no_x11_askpass}
392 %files askpass
393 %defattr(-,root,root)
394 %doc x11-ssh-askpass-%{aversion}/README
395 %doc x11-ssh-askpass-%{aversion}/ChangeLog
396 %doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
397 %attr(0755,root,root) %{_libexecdir}/openssh/ssh-askpass
398 %attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
399 %endif
400
401 %if ! %{no_gnome_askpass}
402 %files askpass-gnome
403 %defattr(-,root,root)
404 %attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
405 %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
406 %endif
407
408 %changelog
409 * Wed Jul 14 2010 Tim Rice <tim@multitalents.net>
410 - test for skip_x11_askpass (line 77) should have been for no_x11_askpass
411
412 * Mon Jun 2 2003 Damien Miller <djm@mindrot.org>
413 - Remove noip6 option. This may be controlled at run-time in client config
414   file using new AddressFamily directive
415
416 * Mon May 12 2003 Damien Miller <djm@mindrot.org>
417 - Don't install profile.d scripts when not building with GNOME/GTK askpass
418   (patch from bet@rahul.net)
419
420 * Wed Oct 01 2002 Damien Miller <djm@mindrot.org>
421 - Install ssh-agent setgid nobody to prevent ptrace() key theft attacks
422
423 * Mon Sep 30 2002 Damien Miller <djm@mindrot.org>
424 - Use contrib/ Makefile for building askpass programs
425
426 * Fri Jun 21 2002 Damien Miller <djm@mindrot.org>
427 - Merge in spec changes from seba@iq.pl (Sebastian Pachuta)
428 - Add new {ssh,sshd}_config.5 manpages
429 - Add new ssh-keysign program and remove setuid from ssh client
430
431 * Fri May 10 2002 Damien Miller <djm@mindrot.org>
432 - Merge in spec changes from RedHat, reorgansie a little
433 - Add Privsep user, group and directory
434
435 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-2
436 - bump and grind (through the build system)
437
438 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-1
439 - require sharutils for building (mindrot #137)
440 - require db1-devel only when building for 6.x (#55105), which probably won't
441   work anyway (3.1 requires OpenSSL 0.9.6 to build), but what the heck
442 - require pam-devel by file (not by package name) again
443 - add Markus's patch to compile with OpenSSL 0.9.5a (from
444   http://bugzilla.mindrot.org/show_bug.cgi?id=141) and apply it if we're
445   building for 6.x
446
447 * Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 3.1p1-0
448 - update to 3.1p1
449
450 * Tue Mar  5 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020305
451 - update to SNAP-20020305
452 - drop debug patch, fixed upstream
453
454 * Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> SNAP-20020220
455 - update to SNAP-20020220 for testing purposes (you've been warned, if there's
456   anything to be warned about, gss patches won't apply, I don't mind)
457
458 * Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-3
459 - add patches from Simon Wilkinson and Nicolas Williams for GSSAPI key
460   exchange, authentication, and named key support
461
462 * Wed Jan 23 2002 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-2
463 - remove dependency on db1-devel, which has just been swallowed up whole
464   by gnome-libs-devel
465
466 * Sun Dec 29 2001 Nalin Dahyabhai <nalin@redhat.com>
467 - adjust build dependencies so that build6x actually works right (fix
468   from Hugo van der Kooij)
469
470 * Tue Dec  4 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.2p1-1
471 - update to 3.0.2p1
472
473 * Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0.1p1-1
474 - update to 3.0.1p1
475
476 * Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
477 - update to current CVS (not for use in distribution)
478
479 * Thu Nov  8 2001 Nalin Dahyabhai <nalin@redhat.com> 3.0p1-1
480 - merge some of Damien Miller <djm@mindrot.org> changes from the upstream
481   3.0p1 spec file and init script
482
483 * Wed Nov  7 2001 Nalin Dahyabhai <nalin@redhat.com>
484 - update to 3.0p1
485 - update to x11-ssh-askpass 1.2.4.1
486 - change build dependency on a file from pam-devel to the pam-devel package
487 - replace primes with moduli
488
489 * Thu Sep 27 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-9
490 - incorporate fix from Markus Friedl's advisory for IP-based authorization bugs
491
492 * Thu Sep 13 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.9p2-8
493 - Merge changes to rescue build from current sysadmin survival cd
494
495 * Thu Sep  6 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-7
496 - fix scp's server's reporting of file sizes, and build with the proper
497   preprocessor define to get large-file capable open(), stat(), etc.
498   (sftp has been doing this correctly all along) (#51827)
499 - configure without --with-ipv4-default on RHL 7.x and newer (#45987,#52247)
500 - pull cvs patch to fix support for /etc/nologin for non-PAM logins (#47298)
501 - mark profile.d scriptlets as config files (#42337)
502 - refer to Jason Stone's mail for zsh workaround for exit-hanging quasi-bug
503 - change a couple of log() statements to debug() statements (#50751)
504 - pull cvs patch to add -t flag to sshd (#28611)
505 - clear fd_sets correctly (one bit per FD, not one byte per FD) (#43221)
506
507 * Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com> 2.9p2-6
508 - add db1-devel as a BuildPrerequisite (noted by Hans Ecke)
509
510 * Thu Aug 16 2001 Nalin Dahyabhai <nalin@redhat.com>
511 - pull cvs patch to fix remote port forwarding with protocol 2
512
513 * Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com>
514 - pull cvs patch to add session initialization to no-pty sessions
515 - pull cvs patch to not cut off challengeresponse auth needlessly
516 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
517   it by default on a system that doesn't have X installed (#49263)
518
519 * Wed Aug  8 2001 Nalin Dahyabhai <nalin@redhat.com>
520 - don't apply patches to code we don't intend to build (spotted by Matt Galgoci)
521
522 * Mon Aug  6 2001 Nalin Dahyabhai <nalin@redhat.com>
523 - pass OPTIONS correctly to initlog (#50151)
524
525 * Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
526 - switch to x11-ssh-askpass 1.2.2
527
528 * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
529 - rebuild in new environment
530
531 * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
532 - disable the gssapi patch
533
534 * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
535 - update to 2.9p2
536 - refresh to a new version of the gssapi patch
537
538 * Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
539 - change Copyright: BSD to License: BSD
540 - add Markus Friedl's unverified patch for the cookie file deletion problem
541   so that we can verify it
542 - drop patch to check if xauth is present (was folded into cookie patch)
543 - don't apply gssapi patches for the errata candidate
544 - clear supplemental groups list at startup
545
546 * Fri May 25 2001 Nalin Dahyabhai <nalin@redhat.com>
547 - fix an error parsing the new default sshd_config
548 - add a fix from Markus Friedl (via openssh-unix-dev) for ssh-keygen not
549   dealing with comments right
550
551 * Thu May 24 2001 Nalin Dahyabhai <nalin@redhat.com>
552 - add in Simon Wilkinson's GSSAPI patch to give it some testing in-house,
553   to be removed before the next beta cycle because it's a big departure
554   from the upstream version
555
556 * Thu May  3 2001 Nalin Dahyabhai <nalin@redhat.com>
557 - finish marking strings in the init script for translation
558 - modify init script to source /etc/sysconfig/sshd and pass $OPTIONS to sshd
559   at startup (change merged from openssh.com init script, originally by
560   Pekka Savola)
561 - refuse to do X11 forwarding if xauth isn't there, handy if you enable
562   it by default on a system that doesn't have X installed
563
564 * Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com>
565 - update to 2.9
566 - drop various patches that came from or went upstream or to or from CVS
567
568 * Wed Apr 18 2001 Nalin Dahyabhai <nalin@redhat.com>
569 - only require initscripts 5.00 on 6.2 (reported by Peter Bieringer)
570
571 * Sun Apr  8 2001 Preston Brown <pbrown@redhat.com>
572 - remove explicit openssl requirement, fixes builddistro issue
573 - make initscript stop() function wait until sshd really dead to avoid
574   races in condrestart
575
576 * Mon Apr  2 2001 Nalin Dahyabhai <nalin@redhat.com>
577 - mention that challengereponse supports PAM, so disabling password doesn't
578   limit users to pubkey and rsa auth (#34378)
579 - bypass the daemon() function in the init script and call initlog directly,
580   because daemon() won't start a daemon it detects is already running (like
581   open connections)
582 - require the version of openssl we had when we were built
583
584 * Fri Mar 23 2001 Nalin Dahyabhai <nalin@redhat.com>
585 - make do_pam_setcred() smart enough to know when to establish creds and
586   when to reinitialize them
587 - add in a couple of other fixes from Damien for inclusion in the errata
588
589 * Thu Mar 22 2001 Nalin Dahyabhai <nalin@redhat.com>
590 - update to 2.5.2p2
591 - call setcred() again after initgroups, because the "creds" could actually
592   be group memberships
593
594 * Tue Mar 20 2001 Nalin Dahyabhai <nalin@redhat.com>
595 - update to 2.5.2p1 (includes endianness fixes in the rijndael implementation)
596 - don't enable challenge-response by default until we find a way to not
597   have too many userauth requests (we may make up to six pubkey and up to
598   three password attempts as it is)
599 - remove build dependency on rsh to match openssh.com's packages more closely
600
601 * Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
602 - remove dependency on openssl -- would need to be too precise
603
604 * Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
605 - rebuild in new environment
606
607 * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
608 - Revert the patch to move pam_open_session.
609 - Init script and spec file changes from Pekka Savola. (#28750)
610 - Patch sftp to recognize '-o protocol' arguments. (#29540)
611
612 * Thu Feb 22 2001 Nalin Dahyabhai <nalin@redhat.com>
613 - Chuck the closing patch.
614 - Add a trigger to add host keys for protocol 2 to the config file, now that
615   configuration file syntax requires us to specify it with HostKey if we
616   specify any other HostKey values, which we do.
617
618 * Tue Feb 20 2001 Nalin Dahyabhai <nalin@redhat.com>
619 - Redo patch to move pam_open_session after the server setuid()s to the user.
620 - Rework the nopam patch to use be picked up by autoconf.
621
622 * Mon Feb 19 2001 Nalin Dahyabhai <nalin@redhat.com>
623 - Update for 2.5.1p1.
624 - Add init script mods from Pekka Savola.
625 - Tweak the init script to match the CVS contrib script more closely.
626 - Redo patch to ssh-add to try to adding both identity and id_dsa to also try
627   adding id_rsa.
628
629 * Fri Feb 16 2001 Nalin Dahyabhai <nalin@redhat.com>
630 - Update for 2.5.0p1.
631 - Use $RPM_OPT_FLAGS instead of -O when building gnome-ssh-askpass
632 - Resync with parts of Damien Miller's openssh.spec from CVS, including
633   update of x11 askpass to 1.2.0.
634 - Only require openssl (don't prereq) because we generate keys in the init
635   script now.
636
637 * Tue Feb 13 2001 Nalin Dahyabhai <nalin@redhat.com>
638 - Don't open a PAM session until we've forked and become the user (#25690).
639 - Apply Andrew Bartlett's patch for letting pam_authenticate() know which
640   host the user is attempting a login from.
641 - Resync with parts of Damien Miller's openssh.spec from CVS.
642 - Don't expose KbdInt responses in debug messages (from CVS).
643 - Detect and handle errors in rsa_{public,private}_decrypt (from CVS).
644
645 * Wed Feb  7 2001 Trond Eivind Glomsrxd <teg@redhat.com>
646 - i18n-tweak to initscript.
647
648 * Tue Jan 23 2001 Nalin Dahyabhai <nalin@redhat.com>
649 - More gettextizing.
650 - Close all files after going into daemon mode (needs more testing).
651 - Extract patch from CVS to handle auth banners (in the client).
652 - Extract patch from CVS to handle compat weirdness.
653
654 * Fri Jan 19 2001 Nalin Dahyabhai <nalin@redhat.com>
655 - Finish with the gettextizing.
656
657 * Thu Jan 18 2001 Nalin Dahyabhai <nalin@redhat.com>
658 - Fix a bug in auth2-pam.c (#23877)
659 - Gettextize the init script.
660
661 * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
662 - Incorporate a switch for using PAM configs for 6.x, just in case.
663
664 * Tue Dec  5 2000 Nalin Dahyabhai <nalin@redhat.com>
665 - Incorporate Bero's changes for a build specifically for rescue CDs.
666
667 * Wed Nov 29 2000 Nalin Dahyabhai <nalin@redhat.com>
668 - Don't treat pam_setcred() failure as fatal unless pam_authenticate() has
669   succeeded, to allow public-key authentication after a failure with "none"
670   authentication.  (#21268)
671
672 * Tue Nov 28 2000 Nalin Dahyabhai <nalin@redhat.com>
673 - Update to x11-askpass 1.1.1. (#21301)
674 - Don't second-guess fixpaths, which causes paths to get fixed twice. (#21290)
675
676 * Mon Nov 27 2000 Nalin Dahyabhai <nalin@redhat.com>
677 - Merge multiple PAM text messages into subsequent prompts when possible when
678   doing keyboard-interactive authentication.
679
680 * Sun Nov 26 2000 Nalin Dahyabhai <nalin@redhat.com>
681 - Disable the built-in MD5 password support.  We're using PAM.
682 - Take a crack at doing keyboard-interactive authentication with PAM, and
683   enable use of it in the default client configuration so that the client
684   will try it when the server disallows password authentication.
685 - Build with debugging flags.  Build root policies strip all binaries anyway.
686
687 * Tue Nov 21 2000 Nalin Dahyabhai <nalin@redhat.com>
688 - Use DESTDIR instead of %%makeinstall.
689 - Remove /usr/X11R6/bin from the path-fixing patch.
690
691 * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
692 - Add the primes file from the latest snapshot to the main package (#20884).
693 - Add the dev package to the prereq list (#19984).
694 - Remove the default path and mimic login's behavior in the server itself.
695
696 * Fri Nov 17 2000 Nalin Dahyabhai <nalin@redhat.com>
697 - Resync with conditional options in Damien Miller's .spec file for an errata.
698 - Change libexecdir from %%{_libexecdir}/ssh to %%{_libexecdir}/openssh.
699
700 * Tue Nov  7 2000 Nalin Dahyabhai <nalin@redhat.com>
701 - Update to OpenSSH 2.3.0p1.
702 - Update to x11-askpass 1.1.0.
703 - Enable keyboard-interactive authentication.
704
705 * Mon Oct 30 2000 Nalin Dahyabhai <nalin@redhat.com>
706 - Update to ssh-askpass-x11 1.0.3.
707 - Change authentication related messages to be private (#19966).
708
709 * Tue Oct 10 2000 Nalin Dahyabhai <nalin@redhat.com>
710 - Patch ssh-keygen to be able to list signatures for DSA public key files
711   it generates.
712
713 * Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
714 - Add BuildRequires on /usr/include/security/pam_appl.h to be sure we always
715   build PAM authentication in.
716 - Try setting SSH_ASKPASS if gnome-ssh-askpass is installed.
717 - Clean out no-longer-used patches.
718 - Patch ssh-add to try to add both identity and id_dsa, and to error only
719   when neither exists.
720
721 * Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
722 - Update x11-askpass to 1.0.2. (#17835)
723 - Add BuildRequiress for /bin/login and /usr/bin/rsh so that configure will
724   always find them in the right place. (#17909)
725 - Set the default path to be the same as the one supplied by /bin/login, but
726   add /usr/X11R6/bin. (#17909)
727 - Try to handle obsoletion of ssh-server more cleanly.  Package names
728   are different, but init script name isn't. (#17865)
729
730 * Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
731 - Update to 2.2.0p1. (#17835)
732 - Tweak the init script to allow proper restarting. (#18023)
733
734 * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
735 - Update to 20000823 snapshot.
736 - Change subpackage requirements from %%{version} to %%{version}-%%{release}
737 - Back out the pipe patch.
738
739 * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
740 - Update to 2.1.1p4, which includes fixes for config file parsing problems.
741 - Move the init script back.
742 - Add Damien's quick fix for wackiness.
743
744 * Wed Jul 12 2000 Nalin Dahyabhai <nalin@redhat.com>
745 - Update to 2.1.1p3, which includes fixes for X11 forwarding and strtok().
746
747 * Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
748 - Move condrestart to server postun.
749 - Move key generation to init script.
750 - Actually use the right patch for moving the key generation to the init script.
751 - Clean up the init script a bit.
752
753 * Wed Jul  5 2000 Nalin Dahyabhai <nalin@redhat.com>
754 - Fix X11 forwarding, from mail post by Chan Shih-Ping Richard.
755
756 * Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
757 - Update to 2.1.1p2.
758 - Use of strtok() considered harmful.
759
760 * Sat Jul  1 2000 Nalin Dahyabhai <nalin@redhat.com>
761 - Get the build root out of the man pages.
762
763 * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
764 - Add and use condrestart support in the init script.
765 - Add newer initscripts as a prereq.
766
767 * Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
768 - Build in new environment (release 2)
769 - Move -clients subpackage to Applications/Internet group
770
771 * Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
772 - Update to 2.2.1p1
773
774 * Sat Jun  3 2000 Nalin Dahyabhai <nalin@redhat.com>
775 - Patch to build with neither RSA nor RSAref.
776 - Miscellaneous FHS-compliance tweaks.
777 - Fix for possibly-compressed man pages.
778
779 * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
780 - Updated for new location
781 - Updated for new gnome-ssh-askpass build
782
783 * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
784 - Added Jim Knoble's <jmknoble@pobox.com> askpass
785
786 * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
787 - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
788
789 * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
790 - Added 'Obsoletes' directives
791
792 * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
793 - Use make install
794 - Subpackages
795
796 * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
797 - Added links for slogin
798 - Fixed perms on manpages
799
800 * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
801 - Renamed init script
802
803 * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
804 - Back to old binary names
805
806 * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
807 - Use autoconf
808 - New binary names
809
810 * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
811 - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.