]> CyberLeo.Net >> Repos - FreeBSD/releng/9.2.git/blob - contrib/dialog/package/dialog.spec
- Copy stable/9 to releng/9.2 as part of the 9.2-RELEASE cycle.
[FreeBSD/releng/9.2.git] / contrib / dialog / package / dialog.spec
1 Summary: dialog - display dialog boxes from shell scripts
2 %define AppProgram dialog
3 %define AppVersion 1.1
4 %define AppRelease 20110707
5 %define ActualProg c%{AppProgram}
6 # $XTermId: dialog.spec,v 1.24 2011/07/07 22:10:02 tom Exp $
7 Name: %{ActualProg}
8 Version: %{AppVersion}
9 Release: %{AppRelease}
10 License: LGPL
11 Group: Applications/Development
12 URL: ftp://invisible-island.net/%{AppProgram}
13 Source0: %{AppProgram}-%{AppVersion}-%{AppRelease}.tgz
14 Packager: Thomas Dickey <dickey@invisible-island.net>
15
16 %description
17 Dialog is a program that will let you to present a variety of questions
18 or display messages using dialog boxes  from  a  shell  script.   These
19 types  of  dialog boxes are implemented (though not all are necessarily
20 compiled into dialog):
21
22       calendar, checklist, dselect, editbox, form, fselect, gauge,
23       infobox, inputbox, inputmenu, menu, mixedform, mixedgauge,
24       msgbox (message), passwordbox, passwordform, pause, progressbox,
25       radiolist, tailbox, tailboxbg, textbox, timebox, and yesno
26       (yes/no).
27
28 This package installs as "cdialog" to avoid conflict with other packages.
29 %prep
30
31 %setup -q -n %{AppProgram}-%{AppVersion}-%{AppRelease}
32
33 %build
34
35 INSTALL_PROGRAM='${INSTALL}' \
36         ./configure \
37                 --target %{_target_platform} \
38                 --prefix=%{_prefix} \
39                 --bindir=%{_bindir} \
40                 --libdir=%{_libdir} \
41                 --mandir=%{_mandir} \
42                 --with-package=%{ActualProg} \
43                 --enable-header-subdir \
44                 --enable-nls \
45                 --enable-widec \
46                 --with-libtool \
47                 --with-ncursesw \
48                 --disable-rpath-hack
49
50 make
51
52 %install
53 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
54
55 make install-full               DESTDIR=$RPM_BUILD_ROOT
56
57 strip $RPM_BUILD_ROOT%{_bindir}/%{ActualProg}
58
59 %clean
60 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(-,root,root)
64 %{_bindir}/%{ActualProg}
65 %{_bindir}/%{ActualProg}-config
66 %{_mandir}/man1/%{ActualProg}.*
67 %{_mandir}/man3/%{ActualProg}.*
68 %{_includedir}/%{ActualProg}.h
69 %{_includedir}/%{ActualProg}/dlg_colors.h
70 %{_includedir}/%{ActualProg}/dlg_config.h
71 %{_includedir}/%{ActualProg}/dlg_keys.h
72 %{_libdir}/lib%{ActualProg}.*
73 %{_datadir}/locale/*/LC_MESSAGES/%{ActualProg}.mo 
74
75 %changelog
76 # each patch should add its ChangeLog entries here
77
78 * Thu Dec 30 2010 Thomas Dickey
79 - initial version