]> CyberLeo.Net >> Repos - FreeBSD/releng/9.2.git/blob - crypto/heimdal/packages/debian/patches/026_posix_max
- Copy stable/9 to releng/9.2 as part of the 9.2-RELEASE cycle.
[FreeBSD/releng/9.2.git] / crypto / heimdal / packages / debian / patches / 026_posix_max
1 Index: heimdal-0.7.2/appl/kf/kf_locl.h
2 ===================================================================
3 --- heimdal-0.7.2.orig/appl/kf/kf_locl.h        2002-09-05 06:29:04.000000000 +1000
4 +++ heimdal-0.7.2/appl/kf/kf_locl.h     2006-03-09 12:59:30.120809192 +1100
5 @@ -79,3 +79,7 @@
6  #define KF_PORT_NAME           "kf"
7  #define KF_PORT_NUM            2110
8  #define KF_VERSION_1           "KFWDV0.1"
9 +
10 +#ifndef MAXPATHLEN
11 +#define MAXPATHLEN 4096
12 +#endif
13 Index: heimdal-0.7.2/appl/kf/kfd.c
14 ===================================================================
15 --- heimdal-0.7.2.orig/appl/kf/kfd.c    2005-05-27 23:43:24.000000000 +1000
16 +++ heimdal-0.7.2/appl/kf/kfd.c 2006-03-09 12:59:30.121809040 +1100
17 @@ -128,7 +128,7 @@
18      krb5_ticket *ticket;
19      char *name;
20      char ret_string[10];
21 -    char hostname[MAXHOSTNAMELEN];
22 +    char hostname[MaxHostNameLen];
23      krb5_data data;
24      krb5_data remotename;
25      krb5_data tk_file;
26 Index: heimdal-0.7.2/appl/kx/kx.h
27 ===================================================================
28 --- heimdal-0.7.2.orig/appl/kx/kx.h     2003-04-17 02:45:43.000000000 +1000
29 +++ heimdal-0.7.2/appl/kx/kx.h  2006-03-09 12:59:30.122808888 +1100
30 @@ -107,6 +107,10 @@
31  #include <sys/stropts.h>
32  #endif
33  
34 +#ifndef MAXPATHLEN
35 +#define MAXPATHLEN 4096
36 +#endif
37 +
38  /* defined by aix's sys/stream.h and again by arpa/nameser.h */
39  
40  #undef NOERROR
41 Index: heimdal-0.7.2/appl/login/login_access.c
42 ===================================================================
43 --- heimdal-0.7.2.orig/appl/login/login_access.c        2001-06-05 00:09:45.000000000 +1000
44 +++ heimdal-0.7.2/appl/login/login_access.c     2006-03-09 12:59:30.123808736 +1100
45 @@ -163,11 +163,11 @@
46  
47  static char *myhostname(void)
48  {
49 -    static char name[MAXHOSTNAMELEN + 1] = "";
50 +    static char name[MaxHostNameLen + 1] = "";
51  
52      if (name[0] == 0) {
53         gethostname(name, sizeof(name));
54 -       name[MAXHOSTNAMELEN] = 0;
55 +       name[MaxHostNameLen] = 0;
56      }
57      return (name);
58  }
59 Index: heimdal-0.7.2/appl/login/login_locl.h
60 ===================================================================
61 --- heimdal-0.7.2.orig/appl/login/login_locl.h  2005-04-23 01:38:54.000000000 +1000
62 +++ heimdal-0.7.2/appl/login/login_locl.h       2006-03-09 12:59:30.124808584 +1100
63 @@ -150,6 +150,10 @@
64  #endif
65  
66  
67 +#ifndef MAXPATHLEN
68 +#define MAXPATHLEN 4096
69 +#endif
70 +
71  struct spwd;
72  
73  extern char **env;
74 Index: heimdal-0.7.2/appl/popper/popper.h
75 ===================================================================
76 --- heimdal-0.7.2.orig/appl/popper/popper.h     2004-07-14 19:10:30.000000000 +1000
77 +++ heimdal-0.7.2/appl/popper/popper.h  2006-03-09 12:59:30.125808432 +1100
78 @@ -154,6 +154,10 @@
79  #define POP_MAILDIR    "/usr/spool/mail"
80  #endif
81  
82 +#ifndef MAXPATHLEN
83 +#define MAXPATHLEN 4096
84 +#endif
85 +
86  #define POP_DROP        POP_MAILDIR "/.%s.pop"
87         /* POP_TMPSIZE needs to be big enough to hold the string
88          * defined by POP_TMPDROP.  POP_DROP and POP_TMPDROP
89 Index: heimdal-0.7.2/appl/rcp/rcp_locl.h
90 ===================================================================
91 --- heimdal-0.7.2.orig/appl/rcp/rcp_locl.h      2005-05-30 04:24:43.000000000 +1000
92 +++ heimdal-0.7.2/appl/rcp/rcp_locl.h   2006-03-09 12:59:30.125808432 +1100
93 @@ -65,3 +65,7 @@
94  #endif
95  #undef _PATH_RSH
96  #define        _PATH_RSH       BINDIR "/rsh"
97 +
98 +#ifndef MAXPATHLEN
99 +#define MAXPATHLEN 4096
100 +#endif
101 Index: heimdal-0.7.2/appl/rsh/rsh_locl.h
102 ===================================================================
103 --- heimdal-0.7.2.orig/appl/rsh/rsh_locl.h      2005-12-29 05:00:05.000000000 +1100
104 +++ heimdal-0.7.2/appl/rsh/rsh_locl.h   2006-03-09 12:59:30.126808280 +1100
105 @@ -172,3 +172,7 @@
106  #define do_write(F, B, L, I) write((F), (B), (L))
107  #define do_read(F, B, L, I) read((F), (B), (L))
108  #endif
109 +
110 +#ifndef MAXPATHLEN
111 +#define MAXPATHLEN 4096
112 +#endif
113 Index: heimdal-0.7.2/appl/test/tcp_server.c
114 ===================================================================
115 --- heimdal-0.7.2.orig/appl/test/tcp_server.c   1999-12-16 21:31:08.000000000 +1100
116 +++ heimdal-0.7.2/appl/test/tcp_server.c        2006-03-09 12:59:30.127808128 +1100
117 @@ -44,7 +44,7 @@
118      krb5_principal server;
119      krb5_ticket *ticket;
120      char *name;
121 -    char hostname[MAXHOSTNAMELEN];
122 +    char hostname[MaxHostNameLen];
123      krb5_data packet;
124      krb5_data data;
125      u_int32_t len, net_len;
126 Index: heimdal-0.7.2/lib/gssapi/gssapi_locl.h
127 ===================================================================
128 --- heimdal-0.7.2.orig/lib/gssapi/gssapi_locl.h 2005-05-31 06:53:46.000000000 +1000
129 +++ heimdal-0.7.2/lib/gssapi/gssapi_locl.h      2006-03-09 12:59:30.128807976 +1100
130 @@ -84,6 +84,10 @@
131   *
132   */
133  
134 +#ifndef MAXPATHLEN
135 +#define MAXPATHLEN 4096
136 +#endif
137 +
138  extern krb5_context gssapi_krb5_context;
139  
140  extern krb5_keytab gssapi_krb5_keytab;
141 Index: heimdal-0.7.2/lib/gssapi/import_name.c
142 ===================================================================
143 --- heimdal-0.7.2.orig/lib/gssapi/import_name.c 2003-03-17 04:33:31.000000000 +1100
144 +++ heimdal-0.7.2/lib/gssapi/import_name.c      2006-03-09 12:59:30.129807824 +1100
145 @@ -90,7 +90,7 @@
146      char *tmp;
147      char *p;
148      char *host;
149 -    char local_hostname[MAXHOSTNAMELEN];
150 +    char local_hostname[MaxHostNameLen];
151  
152      *output_name = NULL;
153  
154 Index: heimdal-0.7.2/lib/kdfs/k5dfspag.c
155 ===================================================================
156 --- heimdal-0.7.2.orig/lib/kdfs/k5dfspag.c      2002-08-13 01:11:58.000000000 +1000
157 +++ heimdal-0.7.2/lib/kdfs/k5dfspag.c   2006-03-09 12:59:30.130807672 +1100
158 @@ -78,6 +78,9 @@
159  #define WAIT_USES_INT
160  typedef krb5_sigtype sigtype;
161  
162 +#ifndef MAXPATHLEN
163 +#define MAXPATHLEN 4096
164 +#endif
165  
166  /* 
167   * Need some syscall numbers based on different systems. 
168 Index: heimdal-0.7.2/lib/krb5/get_addrs.c
169 ===================================================================
170 --- heimdal-0.7.2.orig/lib/krb5/get_addrs.c     2004-05-26 07:26:05.000000000 +1000
171 +++ heimdal-0.7.2/lib/krb5/get_addrs.c  2006-03-09 12:59:30.139806304 +1100
172 @@ -49,7 +49,7 @@
173  gethostname_fallback (krb5_context context, krb5_addresses *res)
174  {
175      krb5_error_code ret;
176 -    char hostname[MAXHOSTNAMELEN];
177 +    char hostname[MaxHostNameLen];
178      struct hostent *hostent;
179  
180      if (gethostname (hostname, sizeof(hostname))) {
181 Index: heimdal-0.7.2/lib/krb5/get_host_realm.c
182 ===================================================================
183 --- heimdal-0.7.2.orig/lib/krb5/get_host_realm.c        2005-04-20 04:52:51.000000000 +1000
184 +++ heimdal-0.7.2/lib/krb5/get_host_realm.c     2006-03-09 12:59:30.140806152 +1100
185 @@ -95,7 +95,7 @@
186                krb5_realm **realms)
187  {
188      static char *default_labels[] = { "_kerberos", NULL };
189 -    char dom[MAXHOSTNAMELEN];
190 +    char dom[MaxHostNameLen];
191      struct dns_reply *r;
192      char **labels;
193      int i, ret;
194 @@ -208,7 +208,7 @@
195                     const char *host,
196                     krb5_realm **realms)
197  {
198 -    char hostname[MAXHOSTNAMELEN];
199 +    char hostname[MaxHostNameLen];
200  
201      if (host == NULL) {
202         if (gethostname (hostname, sizeof(hostname)))
203 Index: heimdal-0.7.2/lib/krb5/krbhst-test.c
204 ===================================================================
205 --- heimdal-0.7.2.orig/lib/krb5/krbhst-test.c   2002-08-23 13:43:18.000000000 +1000
206 +++ heimdal-0.7.2/lib/krb5/krbhst-test.c        2006-03-09 12:59:30.140806152 +1100
207 @@ -87,7 +87,7 @@
208      krb5_init_context (&context);
209      for(i = 0; i < argc; i++) {
210         krb5_krbhst_handle handle;
211 -       char host[MAXHOSTNAMELEN];
212 +       char host[MaxHostNameLen];
213  
214         for (j = 0; j < sizeof(types)/sizeof(*types); ++j) {
215             printf ("%s for %s:\n", type_str[j], argv[i]);
216 Index: heimdal-0.7.2/lib/krb5/krbhst.c
217 ===================================================================
218 --- heimdal-0.7.2.orig/lib/krb5/krbhst.c        2005-05-20 19:09:42.000000000 +1000
219 +++ heimdal-0.7.2/lib/krb5/krbhst.c     2006-03-09 12:59:30.142805848 +1100
220 @@ -763,7 +763,7 @@
221      krb5_error_code ret;
222      int nhost = 0;
223      krb5_krbhst_handle handle;
224 -    char host[MAXHOSTNAMELEN];
225 +    char host[MaxHostNameLen];
226      krb5_krbhst_info *hostinfo;
227  
228      ret = krb5_krbhst_init(context, realm, type, &handle);
229 Index: heimdal-0.7.2/lib/krb5/principal.c
230 ===================================================================
231 --- heimdal-0.7.2.orig/lib/krb5/principal.c     2004-12-29 12:54:54.000000000 +1100
232 +++ heimdal-0.7.2/lib/krb5/principal.c  2006-03-09 12:59:30.150804632 +1100
233 @@ -706,8 +706,8 @@
234      const char *p;
235      krb5_error_code ret;
236      krb5_principal pr;
237 -    char host[MAXHOSTNAMELEN];
238 -    char local_hostname[MAXHOSTNAMELEN];
239 +    char host[MaxHostNameLen];
240 +    char local_hostname[MaxHostNameLen];
241  
242      /* do the following: if the name is found in the
243         `v4_name_convert:host' part, is is assumed to be a `host' type
244 @@ -1059,7 +1059,7 @@
245                          krb5_principal *ret_princ)
246  {
247      krb5_error_code ret;
248 -    char localhost[MAXHOSTNAMELEN];
249 +    char localhost[MaxHostNameLen];
250      char **realms, *host = NULL;
251         
252      if(type != KRB5_NT_SRV_HST && type != KRB5_NT_UNKNOWN) {
253 Index: heimdal-0.7.2/lib/krb5/verify_init.c
254 ===================================================================
255 --- heimdal-0.7.2.orig/lib/krb5/verify_init.c   2004-05-26 07:45:47.000000000 +1000
256 +++ heimdal-0.7.2/lib/krb5/verify_init.c        2006-03-09 12:59:30.151804480 +1100
257 @@ -90,7 +90,7 @@
258      memset (&entry, 0, sizeof(entry));
259  
260      if (ap_req_server == NULL) {
261 -       char local_hostname[MAXHOSTNAMELEN];
262 +       char local_hostname[MaxHostNameLen];
263  
264         if (gethostname (local_hostname, sizeof(local_hostname)) < 0) {
265             ret = errno;
266 Index: heimdal-0.7.2/lib/roken/getaddrinfo_hostspec.c
267 ===================================================================
268 --- heimdal-0.7.2.orig/lib/roken/getaddrinfo_hostspec.c 2005-04-12 21:28:43.000000000 +1000
269 +++ heimdal-0.7.2/lib/roken/getaddrinfo_hostspec.c      2006-03-09 12:59:30.152804328 +1100
270 @@ -48,7 +48,7 @@
271  {
272      const char *p;
273      char portstr[NI_MAXSERV];
274 -    char host[MAXHOSTNAMELEN];
275 +    char host[MaxHostNameLen];
276      struct addrinfo hints;
277      int hostspec_len;
278  
279 Index: heimdal-0.7.2/lib/sl/slc-gram.y
280 ===================================================================
281 --- heimdal-0.7.2.orig/lib/sl/slc-gram.y        2005-04-19 20:28:28.000000000 +1000
282 +++ heimdal-0.7.2/lib/sl/slc-gram.y     2006-03-09 12:59:30.153804176 +1100
283 @@ -46,6 +46,10 @@
284  #include <vers.h>
285  #include <roken.h>
286  
287 +#ifndef PATH_MAX
288 +#define PATH_MAX 4096
289 +#endif
290 +
291  #include "slc.h"
292  extern FILE *yyin;
293  extern struct assignment *a;