]> CyberLeo.Net >> Repos - CDN/portage-cdn.git/blob - sys-block/partclone/partclone-0.3.19.ebuild
sys-block/partclone: new version; remove stale version
[CDN/portage-cdn.git] / sys-block / partclone / partclone-0.3.19.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6
7 inherit autotools
8
9 DESCRIPTION="Partition cloning tool"
10 HOMEPAGE="http://partclone.org"
11 SRC_URI="https://github.com/Thomas-Tsai/partclone/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="btrfs reiserfs reiser4 hfs fat minix ntfs jfs static vmfs xfs f2fs nilfs2"
17
18 RDEPEND="${common_depends}
19         sys-fs/e2fsprogs
20         btrfs? ( sys-fs/btrfs-progs )
21         fat? ( sys-fs/dosfstools )
22         ntfs? ( sys-fs/ntfs3g )
23         hfs? ( sys-fs/hfsutils )
24         jfs? ( sys-fs/jfsutils )
25         reiserfs? ( sys-fs/progsreiserfs )
26         reiser4? ( sys-fs/reiser4progs )
27         xfs? ( >=sys-fs/xfsprogs-3.1.11-r1 )
28         nilfs2? ( >=sys-fs/nilfs-utils-2.1.5-r1 )
29         f2fs? ( >=sys-libs/e2fsprogs-libs-1.42.13 )
30         static? ( sys-fs/e2fsprogs[static-libs]
31                         sys-libs/e2fsprogs-libs[static-libs]
32                         sys-fs/xfsprogs[static-libs]
33                         sys-libs/ncurses[static-libs]
34                         sys-fs/ntfs3g[static-libs]
35                 )"
36 DEPEND=""
37
38 src_prepare() {
39         default
40
41         eautoreconf
42 }
43
44 src_configure()
45 {
46         local myconf
47
48         myconf="${myconf} --enable-extfs --enable-ncursesw --enable-fs-test"
49         use xfs && myconf="${myconf} --enable-xfs"
50         use reiserfs && myconf="${myconf} --enable-reiserfs"
51         use reiser4 && myconf="${myconf} --enable-reiser4"
52         use hfs && myconf="${myconf} --enable-hfsp"
53         use fat && myconf="${myconf} --enable-fat --enable-exfat"
54         use ntfs && myconf="${myconf} --enable-ntfs"
55         use minix && myconf="${myconf} --enable-minix"
56         use jfs && myconf="${myconf} --enable-jfs"
57         use btrfs && myconf="${myconf} --enable-btrfs"
58         use vmfs && myconf="${myconf} --enable-vmfs"
59         use f2fs && myconf="${myconf} --enable-f2fs"
60         use nilfs2 && myconf="${myconf} --enable-nilfs2"
61         use static && myconf="${myconf} --enable-static"
62
63         econf ${myconf} || die "econf failed"
64 }
65
66 src_install()
67 {
68         #emake install || die "make install failed"
69         #emake DIST_ROOT="${D}" install || die "make install failed"
70         cd ${S}/src
71         dosbin partclone.dd partclone.restore partclone.chkimg partclone.info partclone.imager
72         dosbin partclone.extfs
73         dosym /usr/sbin/partclone.extfs /usr/sbin/partclone.ext4
74         dosym /usr/sbin/partclone.extfs /usr/sbin/partclone.ext4dev
75         use xfs && dosbin partclone.xfs
76         use reiserfs && dosbin partclone.reiserfs
77         use reiser4 && dosbin partclone.reiser4
78         use hfs && dosbin partclone.hfsp
79         use fat && (dosbin partclone.fat
80                                 dosym /usr/sbin/partclone.fat /usr/sbin/partclone.fat12
81                                 dosym /usr/sbin/partclone.fat /usr/sbin/partclone.fat16
82                                 dosym /usr/sbin/partclone.fat /usr/sbin/partclone.fat32)
83         use ntfs && dosbin partclone.ntfs
84         use ntfs && (dosbin partclone.ntfsfixboot
85                                  dosym /usr/sbin/partclone.ntfsfixboot /usr/sbin/partclone.ntfsreloc)
86         use btrfs && dosbin partclone.btrfs
87         use f2fs && dosbin partclone.f2fs
88         use nilfs2 && dosbin partclone.nilfs2
89 }
90