]> CyberLeo.Net >> Repos - CDN/portage-cdn.git/blob - sys-fs/zfs-fuse/zfs-fuse-0.7.0-r1.ebuild
Remove sys-kernel/dracut-tuxonice and sys-kernel/dracut-uvesafb
[CDN/portage-cdn.git] / sys-fs / zfs-fuse / zfs-fuse-0.7.0-r1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-fuse/zfs-fuse-0.6.9-r1.ebuild,v 1.4 2010/08/10 10:31:00 ssuominen Exp $
4
5 EAPI=2
6 inherit bash-completion
7
8 DESCRIPTION="An implementation of the ZFS filesystem for FUSE/Linux"
9 HOMEPAGE="http://zfs-fuse.net/"
10 SRC_URI="http://zfs-fuse.net/releases/${PV}/${P}.tar.bz2"
11
12 LICENSE="CDDL"
13 SLOT="0"
14 KEYWORDS="amd64 ~x86"
15 IUSE="debug"
16
17 RDEPEND="dev-libs/libaio
18         dev-libs/openssl
19         sys-fs/fuse
20         sys-libs/zlib"
21 DEPEND="${RDEPEND}
22         dev-util/scons
23         sys-apps/acl
24         sys-apps/attr"
25
26 S=${WORKDIR}/${P}/src
27
28 src_prepare() {
29         epatch "${FILESDIR}/malloc_initialize_hook.patch"
30
31         sed -i \
32                 -e '/LINKFLAGS/s:-s::' \
33                 -e '/CCFLAGS/s:-s -O2::' \
34                 SConstruct || die
35
36         sed -i \
37                 -e 's:../zdb/zdb:/usr/sbin/zdb:' \
38                 cmd/ztest/ztest.c || die
39 }
40
41 src_compile() {
42         local _debug=0
43         use debug && _debug=2
44
45         scons debug=${_debug} || die
46 }
47
48 src_install() {
49         scons \
50                 install_dir="${D}/usr/sbin" \
51                 man_dir="${D}/usr/share/man/man8" \
52                 cfg_dir="${D}/etc/zfs" \
53                 install || die
54
55         insinto /etc/zfs
56         doins ../contrib/zfsrc || die
57
58         keepdir /var/{lock,run}/zfs
59         fowners root.disk /var/{lock,run}/zfs
60
61         doinitd "${FILESDIR}"/${PN}
62
63         dodoc ../{BUGS,CHANGES,HACKING,README*,STATUS,TESTING,TODO}
64
65         dobashcompletion ../contrib/zfs_completion.bash ${PN}
66 }