]> CyberLeo.Net >> Repos - CDN/portage-cdn.git/blob - sys-fs/zfs-fuse/zfs-fuse-0.7.0.ebuild
sys-fs/zfs-fuse: revbump
[CDN/portage-cdn.git] / sys-fs / zfs-fuse / zfs-fuse-0.7.0.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-fs/zfs-fuse/zfs-fuse-0.6.9-r1.ebuild,v 1.4 2010/08/10 10:31:00 ssuominen Exp $
4
5 EAPI=2
6 inherit bash-completion
7
8 DESCRIPTION="An implementation of the ZFS filesystem for FUSE/Linux"
9 HOMEPAGE="http://zfs-fuse.net/"
10 SRC_URI="http://zfs-fuse.net/releases/${PV}/${P}.tar.bz2"
11
12 LICENSE="CDDL"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="debug"
16
17 RDEPEND="dev-libs/libaio
18         dev-libs/openssl
19         sys-fs/fuse
20         sys-libs/zlib"
21 DEPEND="${RDEPEND}
22         dev-util/scons
23         sys-apps/acl
24         sys-apps/attr"
25
26 S=${WORKDIR}/${P}/src
27
28 src_prepare() {
29         sed -i \
30                 -e '/LINKFLAGS/s:-s::' \
31                 -e '/CCFLAGS/s:-s -O2::' \
32                 SConstruct || die
33
34         sed -i \
35                 -e 's:../zdb/zdb:/usr/sbin/zdb:' \
36                 cmd/ztest/ztest.c || die
37 }
38
39 src_compile() {
40         local _debug=0
41         use debug && _debug=2
42
43         scons debug=${_debug} || die
44 }
45
46 src_install() {
47         scons \
48                 install_dir="${D}/usr/sbin" \
49                 man_dir="${D}/usr/share/man/man8" \
50                 cfg_dir="${D}/etc/zfs" \
51                 install || die
52
53         insinto /etc/zfs
54         doins ../contrib/zfsrc || die
55
56         keepdir /var/{lock,run}/zfs
57         fowners root.disk /var/{lock,run}/zfs
58
59         doinitd "${FILESDIR}"/${PN}
60
61         dodoc ../{BUGS,CHANGES,HACKING,README*,STATUS,TESTING,TODO}
62
63         dobashcompletion ../contrib/zfs_completion.bash ${PN}
64 }