]> CyberLeo.Net >> Repos - CDN/portage-cdn.git/blob - sys-fs/zrep/zrep-1.7.3.ebuild
sys-fs/zrep: new ebuild
[CDN/portage-cdn.git] / sys-fs / zrep / zrep-1.7.3.ebuild
1 # Copyright 2017 CyberLeo.Net
2 # http://wiki.cyberleo.net/wiki/CyberLeo/COPYRIGHT
3
4 EAPI=6
5
6 inherit eutils user git-r3
7
8 EGIT_REPO_URI="
9         https://github.com/bolthole/zrep.git
10         git@github.com:bolthole/zrep.git"
11
12 KEYWORDS="~amd64"
13 if [[ $PV = *9999* ]]; then
14         KEYWORDS=""
15 else
16         EGIT_COMMIT="v${PV}"
17 fi
18
19 DESCRIPTION="ZFS based replication and failover solution"
20 HOMEPAGE="http://www.bolthole.com/solaris/zrep/"
21
22 LICENSE="ZREP"
23 SLOT="0"
24 #IUSE=""
25
26 DOCS=( 00-README PORTABILITY )
27
28 CDEPEND="
29         sys-apps/nawk
30         "
31 DEPEND="${CDEPEND}
32         "
33 RDEPEND="${CDEPEND}
34         app-shells/ksh
35         sys-fs/zfs
36         "
37 src_install() {
38         # copy zrep script to expected directory
39         into /usr
40         dosbin zrep
41
42         einstalldocs
43 }