]> CyberLeo.Net >> Repos - CDN/portage-cdn.git/blob - sys-kernel/dracut-uvesafb/dracut-uvesafb-0.ebuild
Fix dracut module scripts to be installed executable
[CDN/portage-cdn.git] / sys-kernel / dracut-uvesafb / dracut-uvesafb-0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6
7 inherit eutils
8
9 DESCRIPTION="Plugin to activate uvesafb for Dracut"
10 HOMEPAGE="https://wiki.gentoo.org/wiki/Dracut#40uvesafb"
11 SRC_URI="http://git.cyberleo.net/releases/${PN}/${P}.tar.xz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
15
16 RDEPEND="sys-kernel/dracut"
17
18 src_install() {
19   default
20
21   local moddir="usr/lib/dracut/modules.d/40uvesafb"
22
23   dodir "${moddir}"
24   exeinto "${moddir}"
25   for d in "${moddir}"/*; do
26     doexe "${d}"
27   done
28 }