]> CyberLeo.Net >> Repos - CDN/portage-cdn.git/blob - www-client/firefox52/firefox52-52.8.0.ebuild
www-client/firefox52: new binary package
[CDN/portage-cdn.git] / www-client / firefox52 / firefox52-52.8.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit gnome2-utils xdg-utils
7
8 DESCRIPTION="Firefox Web Browser"
9 HOMEPAGE=""
10 SRC_URI="https://pkg.cyberleo.net/distfiles/firefox52-52.8.0.txz"
11
12 LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
13 SLOT="52"
14 KEYWORDS="amd64"
15 IUSE=""
16 QA_PREBUILT="*"
17
18 RDEPEND="
19   >=dev-libs/nss-3.28.3
20   >=dev-libs/nspr-4.13.1
21 "
22 DEPEND=""
23
24 src_unpack() {
25   default
26   mkdir -p "${S}"
27   mv "${WORKDIR}/usr" "${S}"
28 }
29
30 src_install() {
31   insinto /
32   doins -r "${S}/usr"
33   exeinto /usr/lib64/firefox52
34   doexe "${S}/usr/lib64/firefox52/firefox"
35   doexe "${S}/usr/lib64/firefox52/firefox-bin"
36   doexe "${S}/usr/lib64/firefox52/run-mozilla.sh"
37   doexe "${S}/usr/lib64/firefox52/plugin-container"
38 }
39
40 pkg_postinst() {
41   gnome2_icon_cache_update
42   xdg_desktop_database_update
43 }
44
45 pkg_postrm() {
46   gnome2_icon_cache_update
47   xdg_desktop_database_update
48 }