]> CyberLeo.Net >> Repos - CDN/portage-cdn.git/blob - x11-apps/disper/disper-0.3.1.ebuild
Remove deleted packages from profile unmask
[CDN/portage-cdn.git] / x11-apps / disper / disper-0.3.1.ebuild
1 # Distributed under the terms of the GNU General Public License v2
2 # $Header: $
3
4 EAPI=4
5 inherit eutils multilib python
6
7 DESCRIPTION="Disper is an on-the-fly display switch utility"
8 HOMEPAGE="http://willem.engen.nl/projects/disper/"
9 SRC_URI="http://ppa.launchpad.net/disper-dev/ppa/ubuntu/pool/main/d/disper/${PN}_${PV}.tar.gz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~x86 ~amd64"
14 IUSE=""
15
16 DEPEND="dev-lang/python"
17 PYTHON_DEPEND="2"
18 RDEPEND="${DEPEND}"
19
20 S="${WORKDIR}/dispercur"
21 src_prepare() {
22     python_convert_shebangs -r 2 .
23     # Avoid running disper within ebuild, since it fails without X
24     [ -f disper.1.in ] && touch disper.1.in
25     sed -i~ 's?`src/disper.py --version|?`echo "${PN} ${PV}"|?' Makefile
26 }
27 src_install() {
28         emake DESTDIR="${D}" install || die "make install failed."
29         doman "${PN}.1"
30         dodoc README
31 }