]> CyberLeo.Net >> Repos - FreeBSD/FreeBSD.git/blob - contrib/dialog/package/dialog.spec
Update libdialog to 1.3-20180621
[FreeBSD/FreeBSD.git] / contrib / dialog / package / dialog.spec
1 Summary: dialog - display dialog boxes from shell scripts
2 %define AppProgram dialog
3 %define AppVersion 1.3
4 %define AppRelease 20180621
5 %define ActualProg c%{AppProgram}
6 # $XTermId: dialog.spec,v 1.108 2018/06/21 09:19:45 tom Exp $
7 Name: %{ActualProg}
8 Version: %{AppVersion}
9 Release: %{AppRelease}
10 License: LGPL
11 Group: Applications/System
12 URL: ftp://ftp.invisible-island.net/%{AppProgram}
13 Source0: %{AppProgram}-%{AppVersion}-%{AppRelease}.tgz
14 Packager: Thomas Dickey <dickey@invisible-island.net>
15
16 %description
17 Dialog is a program that will let you present a variety of questions or
18 display messages using dialog boxes from a shell script.  These types
19 of dialog boxes are implemented (though not all are necessarily compiled
20 into dialog):
21
22      buildlist, calendar, checklist, dselect, editbox, form, fselect,
23      gauge, infobox, inputbox, inputmenu, menu, mixedform,
24      mixedgauge, msgbox (message), passwordbox, passwordform, pause,
25      prgbox, programbox, progressbox, radiolist, rangebox, tailbox,
26      tailboxbg, textbox, timebox, treeview, and yesno (yes/no).
27
28 This package installs as "cdialog" to avoid conflict with other packages.
29 %prep
30
31 %define debug_package %{nil}
32
33 %setup -q -n %{AppProgram}-%{AppVersion}-%{AppRelease}
34
35 %build
36
37 cp -v package/dialog.map package/%{ActualProg}.map
38
39 INSTALL_PROGRAM='${INSTALL}' \
40 %configure \
41         --target %{_target_platform} \
42         --prefix=%{_prefix} \
43         --bindir=%{_bindir} \
44         --libdir=%{_libdir} \
45         --mandir=%{_mandir} \
46         --with-package=%{ActualProg} \
47         --enable-header-subdir \
48         --enable-nls \
49         --enable-widec \
50         --with-shared \
51         --with-ncursesw \
52         --with-versioned-syms \
53         --disable-rpath-hack
54
55 make
56
57 %install
58 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
59
60 make install                    DESTDIR=$RPM_BUILD_ROOT
61 make install-full               DESTDIR=$RPM_BUILD_ROOT
62
63 strip $RPM_BUILD_ROOT%{_bindir}/%{ActualProg}
64 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib%{ActualProg}.so.*
65
66 %clean
67 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(-,root,root)
71 %{_bindir}/%{ActualProg}
72 %{_bindir}/%{ActualProg}-config
73 %{_mandir}/man1/%{ActualProg}.*
74 %{_mandir}/man3/%{ActualProg}.*
75 %{_includedir}/%{ActualProg}.h
76 %{_includedir}/%{ActualProg}/dlg_colors.h
77 %{_includedir}/%{ActualProg}/dlg_config.h
78 %{_includedir}/%{ActualProg}/dlg_keys.h
79 %{_libdir}/lib%{ActualProg}.*
80 %{_datadir}/locale/*/LC_MESSAGES/%{ActualProg}.mo 
81
82 %changelog
83 # each patch should add its ChangeLog entries here
84
85 * Sat Dec 09 2017 Thomas Dickey
86 - update ftp url
87
88 * Thu Apr 21 2016 Thomas Dickey
89 - remove stray call to libtool
90
91 * Tue Oct 18 2011 Thomas Dickey
92 - add executable permissions for shared libraries, discard ".la" file.
93
94 * Thu Dec 30 2010 Thomas Dickey
95 - initial version