]> CyberLeo.Net >> Repos - FreeBSD/releng/10.0.git/blob - contrib/apr-util/apr-util.spec
- Copy stable/10 (r259064) to releng/10.0 as part of the
[FreeBSD/releng/10.0.git] / contrib / apr-util / apr-util.spec
1
2 %define apuver 1
3
4 Summary: Apache Portable Runtime Utility library
5 Name: apr-util
6 Version: 1.5.2
7 Release: 1
8 License: Apache Software License
9 Group: System Environment/Libraries
10 URL: http://apr.apache.org/
11 Source0: http://www.apache.org/dist/apr/%{name}-%{version}.tar.bz2
12 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
13 BuildRequires: autoconf, libtool, doxygen, apr-devel >= 1.4.0
14 BuildRequires: expat-devel, libuuid-devel
15
16 %description
17 The mission of the Apache Portable Runtime (APR) is to provide a
18 free library of C data structures and routines.  This library
19 contains additional utility interfaces for APR; including support
20 for XML, LDAP, database interfaces, URI parsing and more.
21
22 %package devel
23 Group: Development/Libraries
24 Summary: APR utility library development kit
25 Requires: apr-util = %{version}-%{release}, apr-devel
26 Requires: db4-devel, expat-devel
27
28 %description devel
29 This package provides the support files which can be used to 
30 build applications using the APR utility library.  The mission 
31 of the Apache Portable Runtime (APR) is to provide a free 
32 library of C data structures and routines.
33
34 %package dbm
35 Group: Development/Libraries 
36 Summary: APR utility library DBM driver
37 BuildRequires: db4-devel
38 Requires: apr-util = %{version}-%{release}
39
40 %description dbm
41 This package provides the DBM driver for the apr-util.
42
43 %package pgsql
44 Group: Development/Libraries
45 Summary: APR utility library PostgreSQL DBD driver
46 BuildRequires: postgresql-devel
47 Requires: apr-util = %{version}-%{release}
48
49 %description pgsql
50 This package provides the PostgreSQL driver for the apr-util
51 DBD (database abstraction) interface.
52
53 %package mysql
54 Group: Development/Libraries
55 Summary: APR utility library MySQL DBD driver
56 BuildRequires: mysql-devel
57 Requires: apr-util = %{version}-%{release}
58
59 %description mysql
60 This package provides the MySQL driver for the apr-util DBD
61 (database abstraction) interface.
62
63 %package sqlite
64 Group: Development/Libraries
65 Summary: APR utility library SQLite DBD driver
66 BuildRequires: sqlite-devel >= 3.0.0
67 Requires: apr-util = %{version}-%{release}
68
69 %description sqlite
70 This package provides the SQLite driver for the apr-util DBD
71 (database abstraction) interface.
72
73 %package freetds
74 Group: Development/Libraries
75 Summary: APR utility library FreeTDS DBD driver
76 BuildRequires: freetds-devel
77 Requires: apr-util = %{version}-%{release}
78
79 %description freetds
80 This package provides the FreeTDS driver for the apr-util DBD
81 (database abstraction) interface.
82
83 %package odbc
84 Group: Development/Libraries
85 Summary: APR utility library ODBC DBD driver
86 BuildRequires: unixODBC-devel
87 Requires: apr-util = %{version}-%{release}
88
89 %description odbc
90 This package provides the ODBC driver for the apr-util DBD
91 (database abstraction) interface.
92
93 %package ldap
94 Group: Development/Libraries
95 Summary: APR utility library LDAP support
96 BuildRequires: openldap-devel
97 Requires: apr-util = %{version}-%{release}
98
99 %description ldap
100 This package provides the LDAP support for the apr-util.
101
102 %package openssl
103 Group: Development/Libraries
104 Summary: APR utility library OpenSSL crypto support
105 BuildRequires: openssl-devel
106 Requires: apr-util = %{version}-%{release}
107
108 %description openssl
109 This package provides crypto support for apr-util based on OpenSSL.
110
111 %package nss
112 Group: Development/Libraries
113 Summary: APR utility library NSS crypto support
114 BuildRequires: nss-devel
115 Requires: apr-util = %{version}-%{release}
116
117 %description nss
118 This package provides crypto support for apr-util based on Mozilla NSS.
119
120 %prep
121 %setup -q
122
123 %build
124 %configure --with-apr=%{_prefix} \
125         --includedir=%{_includedir}/apr-%{apuver} \
126         --with-ldap --without-gdbm \
127         --with-sqlite3 --with-pgsql --with-mysql --with-freetds --with-odbc \
128         --with-berkeley-db \
129         --with-crypto --with-openssl --with-nss \
130         --without-sqlite2
131 make %{?_smp_mflags} && make dox
132
133 %check
134 # Run non-interactive tests
135 pushd test
136 make %{?_smp_mflags} all CFLAGS=-fno-strict-aliasing
137 make check || exit 1
138 popd
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142 make install DESTDIR=$RPM_BUILD_ROOT
143
144 # Documentation
145 mv docs/dox/html html
146
147 # Unpackaged files
148 rm -f $RPM_BUILD_ROOT%{_libdir}/aprutil.exp
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post -p /sbin/ldconfig
154
155 %postun -p /sbin/ldconfig
156
157 %files
158 %defattr(-,root,root,-)
159 %doc CHANGES LICENSE NOTICE
160 %{_libdir}/libaprutil-%{apuver}.so.*
161 %dir %{_libdir}/apr-util-%{apuver}
162
163 %files dbm
164 %defattr(-,root,root,-)
165 %{_libdir}/apr-util-%{apuver}/apr_dbm_db*
166
167 %files pgsql
168 %defattr(-,root,root,-)
169 %{_libdir}/apr-util-%{apuver}/apr_dbd_pgsql*
170
171 %files mysql
172 %defattr(-,root,root,-)
173 %{_libdir}/apr-util-%{apuver}/apr_dbd_mysql*
174
175 %files sqlite
176 %defattr(-,root,root,-)
177 %{_libdir}/apr-util-%{apuver}/apr_dbd_sqlite*
178
179 %files freetds
180 %defattr(-,root,root,-)
181 %{_libdir}/apr-util-%{apuver}/apr_dbd_freetds*
182
183 %files odbc
184 %defattr(-,root,root,-)
185 %{_libdir}/apr-util-%{apuver}/apr_dbd_odbc*
186
187 %files ldap
188 %defattr(-,root,root,-)
189 %{_libdir}/apr-util-%{apuver}/apr_ldap*
190
191 %files openssl
192 %defattr(-,root,root,-)
193 %{_libdir}/apr-util-%{apuver}/apr_crypto_openssl*
194
195 %files nss
196 %defattr(-,root,root,-)
197 %{_libdir}/apr-util-%{apuver}/apr_crypto_nss*
198
199 %files devel
200 %defattr(-,root,root,-)
201 %{_bindir}/apu-%{apuver}-config
202 %{_libdir}/libaprutil-%{apuver}.*a
203 %{_libdir}/libaprutil-%{apuver}.so
204 %{_libdir}/pkgconfig/apr-util-%{apuver}.pc
205 %{_includedir}/apr-%{apuver}/*.h
206 %doc --parents html
207
208 %changelog
209 * Tue Jun 22 2004 Graham Leggett <minfrin@sharp.fm> 1.0.0-1
210 - update to support v1.0.0 of APR
211                                                                                 
212 * Tue Jun 22 2004 Graham Leggett <minfrin@sharp.fm> 1.0.0-1
213 - derived from Fedora Core apr.spec
214