]> CyberLeo.Net >> Repos - FreeBSD/releng/10.0.git/blob - contrib/dialog/package/dialog.spec
- Copy stable/10 (r259064) to releng/10.0 as part of the
[FreeBSD/releng/10.0.git] / contrib / dialog / package / dialog.spec
1 Summary: dialog - display dialog boxes from shell scripts
2 %define AppProgram dialog
3 %define AppVersion 1.2
4 %define AppRelease 20130923
5 %define ActualProg c%{AppProgram}
6 # $XTermId: dialog.spec,v 1.54 2013/09/23 23:08:24 tom Exp $
7 Name: %{ActualProg}
8 Version: %{AppVersion}
9 Release: %{AppRelease}
10 License: LGPL
11 Group: Applications/Development
12 URL: ftp://invisible-island.net/%{AppProgram}
13 Source0: %{AppProgram}-%{AppVersion}-%{AppRelease}.tgz
14 Packager: Thomas Dickey <dickey@invisible-island.net>
15
16 %description
17 Dialog is a program that will let you to present a variety of questions
18 or display messages using dialog boxes  from  a  shell  script.   These
19 types  of  dialog boxes are implemented (though not all are necessarily
20 compiled into dialog):
21
22       calendar, checklist, dselect, editbox, form, fselect, gauge,
23       infobox, inputbox, inputmenu, menu, mixedform, mixedgauge,
24       msgbox (message), passwordbox, passwordform, pause, progressbox,
25       radiolist, tailbox, tailboxbg, textbox, timebox, and yesno
26       (yes/no).
27
28 This package installs as "cdialog" to avoid conflict with other packages.
29 %prep
30
31 %define debug_package %{nil}
32
33 %setup -q -n %{AppProgram}-%{AppVersion}-%{AppRelease}
34
35 %build
36
37 INSTALL_PROGRAM='${INSTALL}' \
38         ./configure \
39                 --target %{_target_platform} \
40                 --prefix=%{_prefix} \
41                 --bindir=%{_bindir} \
42                 --libdir=%{_libdir} \
43                 --mandir=%{_mandir} \
44                 --with-package=%{ActualProg} \
45                 --enable-header-subdir \
46                 --enable-nls \
47                 --enable-widec \
48                 --with-libtool \
49                 --with-ncursesw \
50                 --disable-rpath-hack
51
52 make
53
54 %install
55 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
56
57 make install-full               DESTDIR=$RPM_BUILD_ROOT
58 libtool --finish %{_libdir} 
59
60 strip $RPM_BUILD_ROOT%{_bindir}/%{ActualProg}
61 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib%{ActualProg}.so.*.*.*
62 rm -f $RPM_BUILD_ROOT%{_libdir}/lib%{ActualProg}.la
63
64 %clean
65 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(-,root,root)
69 %{_bindir}/%{ActualProg}
70 %{_bindir}/%{ActualProg}-config
71 %{_mandir}/man1/%{ActualProg}.*
72 %{_mandir}/man3/%{ActualProg}.*
73 %{_includedir}/%{ActualProg}.h
74 %{_includedir}/%{ActualProg}/dlg_colors.h
75 %{_includedir}/%{ActualProg}/dlg_config.h
76 %{_includedir}/%{ActualProg}/dlg_keys.h
77 %{_libdir}/lib%{ActualProg}.*
78 %{_datadir}/locale/*/LC_MESSAGES/%{ActualProg}.mo 
79
80 %changelog
81 # each patch should add its ChangeLog entries here
82
83 * Tue Oct 18 2011 Thomas Dickey
84 - add executable permissions for shared libraries, discard ".la" file.
85
86 * Thu Dec 30 2010 Thomas Dickey
87 - initial version