]> CyberLeo.Net >> Repos - CDN/cdn-ports-overlay.git/blob - cdn/ports/dns/py-dns/Makefile
dns/py-dns: resurrect dead port
[CDN/cdn-ports-overlay.git] / cdn / ports / dns / py-dns / Makefile
1 # Created by: Mark Linimon <linimon@lonesome.com>
2 # $FreeBSD$
3
4 PORTNAME=       dns
5 PORTVERSION=    2.3.6
6 PORTREVISION=   2
7 CATEGORIES=     dns python
8 MASTER_SITES=   SF/py${PORTNAME}/py${PORTNAME}/py${PORTNAME}-${PORTVERSION}
9 PKGNAMEPREFIX=  ${PYTHON_PKGNAMEPREFIX}
10 DISTNAME=       pydns-${PORTVERSION}
11
12 MAINTAINER=     rm@FreeBSD.org
13 COMMENT=        DNS (Domain Name Service) library for Python
14
15 LICENSE=        CNRI
16 LICENSE_NAME=   CNRI LICENSE AGREEMENT
17 LICENSE_FILE=   ${WRKSRC}/LICENSE
18 LICENSE_PERMS=  dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
19
20 USES=           python:2.7
21 USE_PYTHON=     distutils autoplist
22
23 PORTDOCS=       README.txt README-guido.txt
24 DOCSDIR=        ${PREFIX}/share/doc/py-dns
25
26 OPTIONS_DEFINE= DOCS
27
28 post-install:
29         @${MKDIR} ${STAGEDIR}${DOCSDIR}
30         ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
31
32 .include <bsd.port.mk>