]> CyberLeo.Net >> Repos - CDN/cdn-ports-overlay.git/blob - cdn/ports/misc-cdn/bash-config/Makefile
Make portlint (somewhat) happy
[CDN/cdn-ports-overlay.git] / cdn / ports / misc-cdn / bash-config / Makefile
1 # $FreeBSD$
2
3 PORTNAME=       bash-config
4 PORTVERSION=    1.0.9
5 PORTREVISION=   1
6 CATEGORIES=     misc-cdn
7 MASTER_SITES=   http://git.cyberleo.net/releases/${PORTNAME}/
8 EXTRACT_SUFX=   .tgz
9
10 MAINTAINER=     cyberleo@cyberleo.net
11 COMMENT=        A framework for easy, modular Bash environment configuration
12
13 VALID_CATEGORIES += misc-cdn
14
15 NO_BUILD=       yes
16
17 OPTIONS_DEFINE= BASHCOMP
18 BASHCOMP_DESC=  Install bash-completion scripts & depends
19 OPTIONS_DEFAULT=BASHCOMP
20
21 PLIST_FILES=    etc/bash-config/virgin \
22                 etc/bash-config/common \
23                 etc/bash-config/inputrc \
24                 etc/bash-config/bash_profile \
25                 etc/bash-config/bash_profile.d/10-inputrc \
26                 etc/bash-config/bash_profile.d/10-local-bin \
27                 etc/bash-config/bash_profile.d/10-prompt \
28                 etc/bash-config/bash_profile.d/10-title \
29                 etc/bash-config/bash_profile.d/20-flag \
30                 etc/bash-config/bash_profile.d/98-dot-bash_profile \
31                 etc/bash-config/bash_profile.d/99-bashrc \
32                 etc/bash-config/bashrc \
33                 etc/bash-config/bashrc.d/00-bash_profile \
34                 etc/bash-config/bashrc.d/10-aliases \
35                 etc/bash-config/bashrc.d/10-bash-completion \
36                 etc/bash-config/bashrc.d/20-flag \
37                 etc/bash-config/bashrc.d/50-rvm \
38                 etc/bash-config/bashrc.d/99-dot-bashrc \
39                 share/bash-config/fixskel \
40                 share/bash-config/fixuser
41
42 PLIST_DIRS=     share/bash-config \
43                 etc/bash-config/bashrc.d \
44                 etc/bash-config/bash_profile.d \
45                 etc/bash-config
46
47 RUN_DEPENDS+=   bash:${PORTSDIR}/shells/bash
48
49 .include <bsd.port.options.mk>
50
51 .if ${PORT_OPTIONS:MBASHCOMP}
52 RUN_DEPENDS+=   ${LOCALBASE}/share/bash-completion/bash_completion.sh:${PORTSDIR}/shells/bash-completion
53
54 PLIST_FILES+=   share/bash-completion/completions/service \
55                 share/bash-completion/completions/zfs
56 .endif
57
58 post-patch:
59         ${REINPLACE_CMD} -i '' -e 's|/usr/local/|${PREFIX}/|g' \
60                 ${WRKSRC}/bash-config/common \
61                 ${WRKSRC}/bash-config/bash_profile \
62                 ${WRKSRC}/bash-config/bash_profile.d/* \
63                 ${WRKSRC}/bash-config/bashrc \
64                 ${WRKSRC}/bash-config/bashrc.d/* \
65                 ${WRKSRC}/share/fixskel \
66                 ${WRKSRC}/share/fixuser
67
68 do-install:
69         ${MKDIR} ${STAGEDIR}${ETCDIR}
70         ${INSTALL_SCRIPT} ${WRKSRC}/bash-config/virgin ${STAGEDIR}${ETCDIR}
71         ${INSTALL_DATA} ${WRKSRC}/bash-config/common ${STAGEDIR}${ETCDIR}
72         ${INSTALL_DATA} ${WRKSRC}/bash-config/bash_profile ${STAGEDIR}${ETCDIR}
73         ( cd ${WRKSRC}/bash-config && ${COPYTREE_SHARE} bash_profile.d ${STAGEDIR}${ETCDIR} )
74         ${INSTALL_DATA} ${WRKSRC}/bash-config/bashrc ${STAGEDIR}${ETCDIR}
75         ( cd ${WRKSRC}/bash-config && ${COPYTREE_SHARE} bashrc.d ${STAGEDIR}${ETCDIR} )
76         ${INSTALL_DATA} ${WRKSRC}/bash-config/inputrc ${STAGEDIR}${ETCDIR}
77         ${MKDIR} ${STAGEDIR}${PREFIX}/share/bash-config
78         ${INSTALL_SCRIPT} ${WRKSRC}/share/fixskel ${STAGEDIR}${DATADIR}
79         ${INSTALL_SCRIPT} ${WRKSRC}/share/fixuser ${STAGEDIR}${DATADIR}
80 .if ${PORT_OPTIONS:MBASHCOMP}
81         ${MKDIR} ${STAGEDIR}${PREFIX}/share/bash-completion/completions
82         ${INSTALL_DATA} ${WRKSRC}/bash-completions/service ${STAGEDIR}${PREFIX}/share/bash-completion/completions
83         ${INSTALL_DATA} ${WRKSRC}/bash-completions/zfs ${STAGEDIR}${PREFIX}/share/bash-completion/completions
84 .endif
85
86 .include <bsd.port.mk>