]> CyberLeo.Net >> Repos - CDN/cdn-ports-overlay.git/blob - cdn/ports/misc-cdn/bash-config/Makefile
misc-cdn/bash-config: STAGING support
[CDN/cdn-ports-overlay.git] / cdn / ports / misc-cdn / bash-config / Makefile
1 # New ports collection makefile for:    bash-config
2 # Date created:                         01 Jan 2011
3 # Whom:                                 CyberLeo <cyberleo@cyberleo.net>
4 #
5 # $FreeBSD$
6 #
7
8 PORTNAME=       bash-config
9 PORTVERSION=    1.0.9
10 PORTREVISION=   1
11 CATEGORIES=     misc-cdn
12 MASTER_SITES=   http://git.cyberleo.net/releases/${PORTNAME}/
13 EXTRACT_SUFX=   .tgz
14
15 MAINTAINER=     cyberleo@cyberleo.net
16 COMMENT=        A framework for easy, modular Bash environment configuration
17
18 VALID_CATEGORIES += misc-cdn
19
20 NO_BUILD=       yes
21
22 OPTIONS_DEFINE= BASHCOMP
23 BASHCOMP_DESC=  Install bash-completion scripts & depends
24 OPTIONS_DEFAULT=BASHCOMP
25
26 PLIST_FILES=    etc/bash-config/virgin \
27                 etc/bash-config/common \
28                 etc/bash-config/inputrc \
29                 etc/bash-config/bash_profile \
30                 etc/bash-config/bash_profile.d/10-inputrc \
31                 etc/bash-config/bash_profile.d/10-local-bin \
32                 etc/bash-config/bash_profile.d/10-prompt \
33                 etc/bash-config/bash_profile.d/10-title \
34                 etc/bash-config/bash_profile.d/20-flag \
35                 etc/bash-config/bash_profile.d/98-dot-bash_profile \
36                 etc/bash-config/bash_profile.d/99-bashrc \
37                 etc/bash-config/bashrc \
38                 etc/bash-config/bashrc.d/00-bash_profile \
39                 etc/bash-config/bashrc.d/10-aliases \
40                 etc/bash-config/bashrc.d/10-bash-completion \
41                 etc/bash-config/bashrc.d/20-flag \
42                 etc/bash-config/bashrc.d/50-rvm \
43                 etc/bash-config/bashrc.d/99-dot-bashrc \
44                 share/bash-config/fixskel \
45                 share/bash-config/fixuser
46
47 PLIST_DIRS=     share/bash-config \
48                 etc/bash-config/bashrc.d \
49                 etc/bash-config/bash_profile.d \
50                 etc/bash-config
51
52 RUN_DEPENDS+=   bash:${PORTSDIR}/shells/bash
53
54 .include <bsd.port.options.mk>
55
56 .if ${PORT_OPTIONS:MBASHCOMP}
57 RUN_DEPENDS+=   ${LOCALBASE}/share/bash-completion/bash_completion.sh:${PORTSDIR}/shells/bash-completion
58
59 PLIST_FILES+=   share/bash-completion/completions/service \
60                 share/bash-completion/completions/zfs
61 .endif
62
63 post-patch:
64         ${REINPLACE_CMD} -i '' -e 's|/usr/local/|${PREFIX}/|g' \
65                 ${WRKSRC}/bash-config/common \
66                 ${WRKSRC}/bash-config/bash_profile \
67                 ${WRKSRC}/bash-config/bash_profile.d/* \
68                 ${WRKSRC}/bash-config/bashrc \
69                 ${WRKSRC}/bash-config/bashrc.d/* \
70                 ${WRKSRC}/share/fixskel \
71                 ${WRKSRC}/share/fixuser
72
73 do-install:
74         ${MKDIR} ${STAGEDIR}${ETCDIR}
75         ${INSTALL_SCRIPT} ${WRKSRC}/bash-config/virgin ${STAGEDIR}${ETCDIR}
76         ${INSTALL_DATA} ${WRKSRC}/bash-config/common ${STAGEDIR}${ETCDIR}
77         ${INSTALL_DATA} ${WRKSRC}/bash-config/bash_profile ${STAGEDIR}${ETCDIR}
78         ( cd ${WRKSRC}/bash-config && ${COPYTREE_SHARE} bash_profile.d ${STAGEDIR}${ETCDIR} )
79         ${INSTALL_DATA} ${WRKSRC}/bash-config/bashrc ${STAGEDIR}${ETCDIR}
80         ( cd ${WRKSRC}/bash-config && ${COPYTREE_SHARE} bashrc.d ${STAGEDIR}${ETCDIR} )
81         ${INSTALL_DATA} ${WRKSRC}/bash-config/inputrc ${STAGEDIR}${ETCDIR}
82         ${MKDIR} ${STAGEDIR}${PREFIX}/share/bash-config
83         ${INSTALL_SCRIPT} ${WRKSRC}/share/fixskel ${STAGEDIR}${DATADIR}
84         ${INSTALL_SCRIPT} ${WRKSRC}/share/fixuser ${STAGEDIR}${DATADIR}
85 .if ${PORT_OPTIONS:MBASHCOMP}
86         ${MKDIR} ${STAGEDIR}${PREFIX}/share/bash-completion/completions
87         ${INSTALL_DATA} ${WRKSRC}/bash-completions/service ${STAGEDIR}${PREFIX}/share/bash-completion/completions
88         ${INSTALL_DATA} ${WRKSRC}/bash-completions/zfs ${STAGEDIR}${PREFIX}/share/bash-completion/completions
89 .endif
90
91 .include <bsd.port.mk>