]> CyberLeo.Net >> Repos - CDN/cdn-ports-overlay.git/blob - cdn/ports/misc-cdn/bash-config/Makefile
misc-cdn/bash-config: remove redundant reinplace
[CDN/cdn-ports-overlay.git] / cdn / ports / misc-cdn / bash-config / Makefile
1 # New ports collection makefile for:    bash-config
2 # Date created:                         01 Jan 2011
3 # Whom:                                 CyberLeo <cyberleo@cyberleo.net>
4 #
5 # $FreeBSD$
6 #
7
8 PORTNAME=       bash-config
9 PORTVERSION=    1.0.9
10 CATEGORIES=     misc-cdn
11 MASTER_SITES=   http://git.cyberleo.net/releases/${PORTNAME}/
12 EXTRACT_SUFX=   .tgz
13
14 MAINTAINER=     cyberleo@cyberleo.net
15 COMMENT=        A framework for easy, modular Bash environment configuration
16
17 VALID_CATEGORIES += misc-cdn
18
19 NO_BUILD=       yes
20
21 OPTIONS_DEFINE= BASHCOMP
22 BASHCOMP_DESC=  Install bash-completion scripts & depends
23 OPTIONS_DEFAULT=BASHCOMP
24
25 PLIST_FILES=    etc/bash-config/virgin \
26                 etc/bash-config/common \
27                 etc/bash-config/inputrc \
28                 etc/bash-config/bash_profile \
29                 etc/bash-config/bash_profile.d/10-inputrc \
30                 etc/bash-config/bash_profile.d/10-local-bin \
31                 etc/bash-config/bash_profile.d/10-prompt \
32                 etc/bash-config/bash_profile.d/10-title \
33                 etc/bash-config/bash_profile.d/20-flag \
34                 etc/bash-config/bash_profile.d/98-dot-bash_profile \
35                 etc/bash-config/bash_profile.d/99-bashrc \
36                 etc/bash-config/bashrc \
37                 etc/bash-config/bashrc.d/00-bash_profile \
38                 etc/bash-config/bashrc.d/10-aliases \
39                 etc/bash-config/bashrc.d/10-bash-completion \
40                 etc/bash-config/bashrc.d/20-flag \
41                 etc/bash-config/bashrc.d/50-rvm \
42                 etc/bash-config/bashrc.d/99-dot-bashrc \
43                 share/bash-config/fixskel \
44                 share/bash-config/fixuser
45
46 PLIST_DIRS=     share/bash-config \
47                 etc/bash-config/bashrc.d \
48                 etc/bash-config/bash_profile.d \
49                 etc/bash-config
50
51 RUN_DEPENDS+=   bash:${PORTSDIR}/shells/bash
52
53 .include <bsd.port.options.mk>
54
55 .if ${PORT_OPTIONS:MBASHCOMP}
56 RUN_DEPENDS+=   ${LOCALBASE}/share/bash-completion/bash_completion.sh:${PORTSDIR}/shells/bash-completion
57
58 PLIST_FILES+=   share/bash-completion/completions/service \
59                 share/bash-completion/completions/zfs
60 .endif
61
62 post-patch:
63         ${REINPLACE_CMD} -i '' -e 's|/usr/local/|${PREFIX}/|g' \
64                 ${WRKSRC}/bash-config/common \
65                 ${WRKSRC}/bash-config/bash_profile \
66                 ${WRKSRC}/bash-config/bash_profile.d/* \
67                 ${WRKSRC}/bash-config/bashrc \
68                 ${WRKSRC}/bash-config/bashrc.d/* \
69                 ${WRKSRC}/share/fixskel \
70                 ${WRKSRC}/share/fixuser
71
72 do-install:
73         ${MKDIR} ${PREFIX}/etc/bash-config
74         ${INSTALL_SCRIPT} ${WRKSRC}/bash-config/virgin ${PREFIX}/etc/bash-config
75         ${INSTALL_DATA} ${WRKSRC}/bash-config/common ${PREFIX}/etc/bash-config
76         ${INSTALL_DATA} ${WRKSRC}/bash-config/bash_profile ${PREFIX}/etc/bash-config
77         ( cd ${WRKSRC}/bash-config && ${COPYTREE_SHARE} bash_profile.d ${PREFIX}/etc/bash-config )
78         ${INSTALL_DATA} ${WRKSRC}/bash-config/bashrc ${PREFIX}/etc/bash-config
79         ( cd ${WRKSRC}/bash-config && ${COPYTREE_SHARE} bashrc.d ${PREFIX}/etc/bash-config )
80         ${INSTALL_DATA} ${WRKSRC}/bash-config/inputrc ${PREFIX}/etc/bash-config
81         ${MKDIR} ${PREFIX}/share/bash-config
82         ${INSTALL_SCRIPT} ${WRKSRC}/share/fixskel ${PREFIX}/share/bash-config
83         ${INSTALL_SCRIPT} ${WRKSRC}/share/fixuser ${PREFIX}/share/bash-config
84 .if ${PORT_OPTIONS:MBASHCOMP}
85         ${MKDIR} ${PREFIX}/share/bash-completion/completions
86         ${INSTALL_DATA} ${WRKSRC}/bash-completions/service ${PREFIX}/share/bash-completion/completions
87         ${INSTALL_DATA} ${WRKSRC}/bash-completions/zfs ${PREFIX}/share/bash-completion/completions
88 .endif
89
90 .include <bsd.port.mk>