]> CyberLeo.Net >> Repos - CDN/cdn-ports-overlay.git/blob - cdn/ports/misc-cdn/cdn-base/Makefile
net/tinyfugue-unicode: Fix build errors
[CDN/cdn-ports-overlay.git] / cdn / ports / misc-cdn / cdn-base / Makefile
1 # $FreeBSD$
2
3 PORTNAME=       cdn-base
4 PORTVERSION=    1.1
5 PORTREVISION=   0
6 CATEGORIES=     misc-cdn
7 MASTER_SITES=   # None
8 DISTFILES=      # None
9
10 MAINTAINER=     cyberleo@cyberleo.net
11 COMMENT=        Depends upon and helps configure ports installed by default
12
13 VALID_CATEGORIES += misc-cdn
14
15 NO_BUILD=       yes
16
17 OPTIONS_DEFINE= BSDSTATS GIT PV RUNIT
18 BSDSTATS_DESC=  Depend on sysutils/bsdstats for stat reporting
19 GIT_DESC=       Depend on devel/git
20 PV_DESC=        Depend on misc/pv for a progress bar
21 RUNIT_DESC=     Depend on sysutils/runit
22 OPTIONS_DEFAULT=BSDSTATS GIT PV RUNIT
23
24 PLIST_FILES=    %%DATADIR%%/setup-cdn-base
25 SUB_FILES=      pkg-message setup-cdn-base
26
27 RUN_DEPENDS+=   portmaster:${PORTSDIR}/ports-mgmt/portmaster \
28                 ${LOCALBASE}/share/bash-config/fixuser:${PORTSDIR}/misc-cdn/bash-config \
29                 flag:${PORTSDIR}/misc/flag \
30                 sudo:${PORTSDIR}/security/sudo \
31                 rsync:${PORTSDIR}/net/rsync \
32                 screen:${PORTSDIR}/sysutils/screen
33
34 #RUN_DEPENDS+=  portaudit:${PORTSDIR}/ports-mgmt/portaudit
35
36 .include <bsd.port.options.mk>
37
38 .if ${PORT_OPTIONS:MBSDSTATS}
39 RUN_DEPENDS+=   bsdstats-send:${PORTSDIR}/sysutils/bsdstats
40 .endif
41
42 .if ${PORT_OPTIONS:MGIT}
43 RUN_DEPENDS+=   git:${PORTSDIR}/devel/git
44 .endif
45
46 .if ${PORT_OPTIONS:MPV}
47 RUN_DEPENDS+=   pv:${PORTSDIR}/sysutils/pv
48 .endif
49
50 .if ${PORT_OPTIONS:MRUNIT}
51 RUN_DEPENDS+=   runit:${PORTSDIR}/sysutils/runit
52 .endif
53
54 do-install: build
55         ${MKDIR} ${STAGEDIR}${DATADIR}
56         ${INSTALL_SCRIPT} ${WRKDIR}/setup-cdn-base ${STAGEDIR}${DATADIR}/setup-cdn-base
57
58 .include <bsd.port.mk>