]> CyberLeo.Net >> Repos - CDN/cdn-ports-overlay.git/blob - cdn/ports/misc-cdn/crc32sum/Makefile
misc-cdn/crc32sum: deprecated by base system 'cksum' binary
[CDN/cdn-ports-overlay.git] / cdn / ports / misc-cdn / crc32sum / Makefile
1 # New ports collection makefile for:    crc32sum
2 # Date created:                         20 Feb 2010
3 # Whom:                                 CyberLeo <cyberleo@cyberleo.net>
4 #
5 # $FreeBSD$
6 #
7
8 PORTNAME=       crc32sum
9 PORTVERSION=    1.0.1
10 CATEGORIES=     misc-cdn
11 MASTER_SITES=   http://git.cyberleo.net/releases/${PORTNAME}/
12 EXTRACT_SUFX=   .tgz
13
14 MAINTAINER=     cyberleo@cyberleo.net
15 COMMENT=        Compute the crc32 checksum of an input file or stdin
16
17 DEPRECATED=     A binary already exists in the base system to compute CRC32 checksums. 
18
19 VALID_CATEGORIES += misc-cdn
20
21 PLIST_FILES=    bin/crc32sum
22
23 MAN1=           crc32sum.1
24
25 .include <bsd.port.pre.mk>
26
27 do-install:
28         ${INSTALL_SCRIPT} ${WRKSRC}/crc32sum ${PREFIX}/bin/crc32sum
29         ${INSTALL_MAN} ${WRKSRC}/crc32sum.1 ${MAN1PREFIX}/man/man1
30
31 .include <bsd.port.post.mk>