]> CyberLeo.Net >> Repos - CDN/cdn-ports-overlay.git/blob - cdn/ports/misc-cdn/flag/Makefile
misc-cdn/flag: STAGING support
[CDN/cdn-ports-overlay.git] / cdn / ports / misc-cdn / flag / Makefile
1 # New ports collection makefile for:    flag
2 # Date created:                         20 February 2010
3 # Whom:                                 CyberLeo <cyberleo@cyberleo.net
4 #
5 # $FreeBSD$
6 #
7
8 PORTNAME=       flag
9 PORTVERSION=    1.0.3
10 PORTREVISION=   1
11 CATEGORIES=     misc-cdn
12 MASTER_SITES=   http://git.cyberleo.net/releases/${PORTNAME}/
13 EXTRACT_SUFX=   .tgz
14
15 MAINTAINER=     cyberleo@cyberleo.net
16 COMMENT=        Turn the hostname into a colourful and visually distinctive ansi flag
17
18 VALID_CATEGORIES += misc-cdn
19
20 NO_BUILD=       yes
21
22 OPTIONS_DEFINE= BASH
23 BASH_DESC=      Install include for Bash prompt
24 OPTIONS_DEFAULT=BASH
25
26 PLIST_FILES=    bin/flag etc/rc.d/update-issue
27
28 .include <bsd.port.options.mk>
29
30 .if ${PORT_OPTIONS:MBASH}
31 PLIST_FILES+=   share/flag/bash_prompt.sh
32 PLIST_DIRS+=    share/flag
33 .endif
34
35 do-install:
36         ${INSTALL_SCRIPT} ${WRKSRC}/flag ${STAGEDIR}${PREFIX}/bin/flag
37         ${INSTALL_SCRIPT} ${WRKSRC}/update-issue ${STAGEDIR}${PREFIX}/etc/rc.d/update-issue
38 .if ${PORT_OPTIONS:MBASH}
39         ${MKDIR} ${STAGEDIR}${DATADIR}
40         ${INSTALL_DATA} ${WRKSRC}/bash_prompt.sh ${STAGEDIR}${DATADIR}
41 .endif
42
43 .include <bsd.port.mk>