]> CyberLeo.Net >> Repos - CDN/cdn-ports-overlay.git/blob - cdn/ports/misc-cdn/shlib/Makefile
misc-cdn/bash-config: include missing plist files
[CDN/cdn-ports-overlay.git] / cdn / ports / misc-cdn / shlib / Makefile
1 # New ports collection makefile for:    shlib
2 # Date created:                         20 Feb 2010
3 # Whom:                                 CyberLeo <cyberleo@cyberleo.net>
4 #
5 # $FreeBSD$
6 #
7
8 PORTNAME=       shlib
9 PORTVERSION=    1.0.1
10 PORTREVISION=   1
11 CATEGORIES=     misc-cdn
12 MASTER_SITES=   http://git.cyberleo.net/releases/${PORTNAME}/
13 EXTRACT_SUFX=   .tgz
14
15 MAINTAINER=     cyberleo@cyberleo.net
16 COMMENT=        A series of modular convenience functions for bourne shell scripting
17
18 VALID_CATEGORIES += misc-cdn
19
20 NO_BUILD=       yes
21
22 PLIST_FILES=    lib/sh/env.sh \
23                 lib/sh/ansi.sh \
24                 lib/sh/ask.sh \
25                 lib/sh/file.sh \
26                 lib/sh/log.sh \
27                 lib/sh/progress.sh \
28                 lib/sh/reexec.sh \
29                 lib/sh/root.sh \
30                 lib/sh/skel.sh \
31                 share/examples/shlib/example.sh
32
33 PLIST_DIRS=     lib/sh \
34                 share/examples/shlib
35
36 .include <bsd.port.pre.mk>
37
38 do-install:
39         ( cd ${WRKSRC}/lib && ${COPYTREE_BIN} sh/ ${PREFIX}/lib )
40         ${MKDIR} ${EXAMPLESDIR}
41         ${INSTALL_SCRIPT} ${WRKSRC}/example.sh ${PREFIX}/share/examples/shlib/example.sh
42
43 .include <bsd.port.post.mk>