]> CyberLeo.Net >> Repos - CDN/cdn-ports-overlay.git/blob - cdn/ports/misc-cdn/shlib/Makefile
misc-cdn/shlib: STAGING support
[CDN/cdn-ports-overlay.git] / cdn / ports / misc-cdn / shlib / Makefile
1 # New ports collection makefile for:    shlib
2 # Date created:                         20 Feb 2010
3 # Whom:                                 CyberLeo <cyberleo@cyberleo.net>
4 #
5 # $FreeBSD$
6 #
7
8 PORTNAME=       shlib
9 PORTVERSION=    1.0.4
10 PORTREVISION=   1
11 CATEGORIES=     misc-cdn
12 MASTER_SITES=   http://git.cyberleo.net/releases/${PORTNAME}/
13 EXTRACT_SUFX=   .tgz
14
15 MAINTAINER=     cyberleo@cyberleo.net
16 COMMENT=        A series of modular convenience functions for bourne shell scripting
17
18 VALID_CATEGORIES += misc-cdn
19
20 PLIST_FILES=    lib/sh/env.sh \
21                 lib/sh/ansi.sh \
22                 lib/sh/ask.sh \
23                 lib/sh/file.sh \
24                 lib/sh/kvs.sh \
25                 lib/sh/log.sh \
26                 lib/sh/progress.sh \
27                 lib/sh/reexec.sh \
28                 lib/sh/root.sh \
29                 lib/sh/skel.sh \
30                 lib/sh/stopwatch.sh \
31                 lib/sh/suexec.sh \
32                 lib/sh/usec \
33                 share/examples/shlib/example.sh
34
35 PLIST_DIRS=     lib/sh \
36                 share/examples/shlib
37
38 .include <bsd.port.pre.mk>
39
40 do-build:
41         $(MAKE) -C ${WRKSRC}/src/usec all install clean
42
43 do-install:
44         ( cd ${WRKSRC}/lib && ${COPYTREE_BIN} sh/ ${STAGEDIR}${PREFIX}/lib )
45         ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
46         ${INSTALL_SCRIPT} ${WRKSRC}/example.sh ${STAGEDIR}${EXAMPLESDIR}/example.sh
47
48 .include <bsd.port.post.mk>