]> CyberLeo.Net >> Repos - CDN/cdn-ports-overlay.git/blob - cdn/ports/misc-cdn/shlib/Makefile
misc-cdn/shlib: Release 1.0.2
[CDN/cdn-ports-overlay.git] / cdn / ports / misc-cdn / shlib / Makefile
1 # New ports collection makefile for:    shlib
2 # Date created:                         20 Feb 2010
3 # Whom:                                 CyberLeo <cyberleo@cyberleo.net>
4 #
5 # $FreeBSD$
6 #
7
8 PORTNAME=       shlib
9 PORTVERSION=    1.0.2
10 CATEGORIES=     misc-cdn
11 MASTER_SITES=   http://git.cyberleo.net/releases/${PORTNAME}/
12 EXTRACT_SUFX=   .tgz
13
14 MAINTAINER=     cyberleo@cyberleo.net
15 COMMENT=        A series of modular convenience functions for bourne shell scripting
16
17 VALID_CATEGORIES += misc-cdn
18
19 NO_BUILD=       yes
20
21 PLIST_FILES=    lib/sh/env.sh \
22                 lib/sh/ansi.sh \
23                 lib/sh/ask.sh \
24                 lib/sh/file.sh \
25                 lib/sh/kvs.sh \
26                 lib/sh/log.sh \
27                 lib/sh/progress.sh \
28                 lib/sh/reexec.sh \
29                 lib/sh/root.sh \
30                 lib/sh/skel.sh \
31                 lib/sh/suexec.sh \
32                 share/examples/shlib/example.sh
33
34 PLIST_DIRS=     lib/sh \
35                 share/examples/shlib
36
37 .include <bsd.port.pre.mk>
38
39 do-install:
40         ( cd ${WRKSRC}/lib && ${COPYTREE_BIN} sh/ ${PREFIX}/lib )
41         ${MKDIR} ${EXAMPLESDIR}
42         ${INSTALL_SCRIPT} ${WRKSRC}/example.sh ${PREFIX}/share/examples/shlib/example.sh
43
44 .include <bsd.port.post.mk>