]> CyberLeo.Net >> Repos - CDN/cdn-ports-overlay.git/blob - cdn/ports/net/tinyfugue-unicode/Makefile
net/tinyfugue-unicode: Tinyfugue with kruton unicode patch
[CDN/cdn-ports-overlay.git] / cdn / ports / net / tinyfugue-unicode / Makefile
1 # Created by: mike@binghamton.edu
2 # $FreeBSD: head/net/tinyfugue/Makefile 436247 2017-03-15 14:45:30Z mat $
3
4 PORTNAME=       tf-unicode
5 PORTVERSION=    5.0b8
6 CATEGORIES=     net games
7
8 USE_GITHUB=     yes
9 GH_ACCOUNT=     kruton
10 GH_PROJECT=     tinyfugue
11 GH_TAGNAME=     fe8fa3242d1eabff56c3af584bc92d60a33ad583
12
13 MAINTAINER=     johans@FreeBSD.org
14 COMMENT=        Popular programmable MUD client, with macro support and more
15
16 LIB_DEPENDS=    libpcre.so:devel/pcre
17
18 GNU_CONFIGURE=  yes
19 CONFIGURE_ARGS= --enable-manpage --enable-version --enable-symlink \
20                 --datadir=${PREFIX}/lib --with-inclibpfx=${LOCALBASE}
21 USES=           ssl
22 LDFLAGS+=       -L${LOCALBASE}
23
24 PLIST_SUB=      DISTNAME=tf-50b8
25
26 post-patch:
27         @${REINPLACE_CMD} 's:@.*dir@:$${DESTDIR}&:' ${WRKSRC}/unix/vars.mak.in
28         @${REINPLACE_CMD} '/ln -s/s@(TF)@(TF:T)@' ${WRKSRC}/unix/unix.mak
29
30 post-build:
31         @${STRIP_CMD} ${WRKSRC}/src/tf
32
33 post-install:
34         ${INSTALL_MAN} ${WRKSRC}/src/tf.1.nroffman ${STAGEDIR}${PREFIX}/man/man1/tf.1
35
36 .include <bsd.port.mk>