]> CyberLeo.Net >> Repos - CDN/cdn-ports-overlay.git/blob - cdn/ports/misc-cdn/cdn-base/Makefile
misc-cdn/cdn-base: add bsdstats to default install
[CDN/cdn-ports-overlay.git] / cdn / ports / misc-cdn / cdn-base / Makefile
1 # $FreeBSD$
2
3 PORTNAME=       cdn-base
4 PORTVERSION=    1.1
5 PORTREVISION=   0
6 CATEGORIES=     misc-cdn
7 MASTER_SITES=   # None
8 DISTFILES=      # None
9
10 MAINTAINER=     cyberleo@cyberleo.net
11 COMMENT=        Depends upon and helps configure ports installed by default
12
13 VALID_CATEGORIES += misc-cdn
14
15 NO_BUILD=       yes
16
17 OPTIONS_DEFINE= BSDSTATS GIT PV
18 BSDSTATS_DESC=  Depend on sysutils/bsdstats for stat reporting
19 GIT_DESC=       Depend on devel/git
20 PV_DESC=        Depend on misc/pv for a progress bar
21 OPTIONS_DEFAULT=BSDSTATS GIT PV
22
23 PLIST_FILES=    %%DATADIR%%/setup-cdn-base
24 SUB_FILES=      pkg-message setup-cdn-base
25
26 RUN_DEPENDS+=   portmaster:${PORTSDIR}/ports-mgmt/portmaster \
27                 ${LOCALBASE}/share/bash-config/fixuser:${PORTSDIR}/misc-cdn/bash-config \
28                 flag:${PORTSDIR}/misc/flag \
29                 sudo:${PORTSDIR}/security/sudo \
30                 rsync:${PORTSDIR}/net/rsync \
31                 screen:${PORTSDIR}/sysutils/screen
32
33 #RUN_DEPENDS+=  portaudit:${PORTSDIR}/ports-mgmt/portaudit
34
35 .include <bsd.port.options.mk>
36
37 .if ${PORT_OPTIONS:MBSDSTATS}
38 RUN_DEPENDS+=   bsdstats-send:${PORTSDIR}/sysutils/bsdstats
39 .endif
40
41 .if ${PORT_OPTIONS:MGIT}
42 RUN_DEPENDS+=   git:${PORTSDIR}/devel/git
43 .endif
44
45 .if ${PORT_OPTIONS:MPV}
46 RUN_DEPENDS+=   pv:${PORTSDIR}/sysutils/pv
47 .endif
48
49 do-install: build
50         ${MKDIR} ${STAGEDIR}${DATADIR}
51         ${INSTALL_SCRIPT} ${WRKDIR}/setup-cdn-base ${STAGEDIR}${DATADIR}/setup-cdn-base
52
53 .include <bsd.port.mk>