]> CyberLeo.Net >> Repos - CDN/cdn-ports-overlay.git/blob - cdn/ports/misc-cdn/cdn-base/Makefile
Make portlint (somewhat) happy
[CDN/cdn-ports-overlay.git] / cdn / ports / misc-cdn / cdn-base / Makefile
1 # $FreeBSD$
2
3 PORTNAME=       cdn-base
4 PORTVERSION=    1.0
5 PORTREVISION=   2
6 CATEGORIES=     misc-cdn
7 MASTER_SITES=   # None
8 DISTFILES=      # None
9
10 MAINTAINER=     cyberleo@cyberleo.net
11 COMMENT=        Depends upon and helps configure ports installed by default
12
13 VALID_CATEGORIES += misc-cdn
14
15 NO_BUILD=       yes
16
17 OPTIONS_DEFINE= GIT PV
18 GIT_DESC=       Depend on devel/git
19 PV_DESC=        Depend on misc/pv for a progress bar
20 OPTIONS_DEFAULT=GIT PV
21
22 PLIST_FILES=    %%DATADIR%%/setup-cdn-base
23 SUB_FILES=      pkg-message setup-cdn-base
24
25 RUN_DEPENDS+=   portaudit:${PORTSDIR}/ports-mgmt/portaudit \
26                 portmaster:${PORTSDIR}/ports-mgmt/portmaster \
27                 ${LOCALBASE}/share/bash-config/fixuser:${PORTSDIR}/misc-cdn/bash-config \
28                 flag:${PORTSDIR}/misc-cdn/flag \
29                 sudo:${PORTSDIR}/security/sudo \
30                 rsync:${PORTSDIR}/net/rsync \
31                 screen:${PORTSDIR}/sysutils/screen
32
33 .include <bsd.port.options.mk>
34
35 .if ${PORT_OPTIONS:MGIT}
36 RUN_DEPENDS+=   git:${PORTSDIR}/devel/git
37 .endif
38
39 .if ${PORT_OPTIONS:MPV}
40 RUN_DEPENDS+=   pv:${PORTSDIR}/sysutils/pv
41 .endif
42
43 do-install: build
44         ${MKDIR} ${STAGEDIR}${DATADIR}
45         ${INSTALL_SCRIPT} ${WRKDIR}/setup-cdn-base ${STAGEDIR}${DATADIR}/setup-cdn-base
46
47 .include <bsd.port.mk>