]> CyberLeo.Net >> Repos - CDN/cdn-ports-overlay.git/blob - cdn/ports/misc-cdn/cdn-base/Makefile
misc-cdn/cdn-base: new port to pull in everything usually installed
[CDN/cdn-ports-overlay.git] / cdn / ports / misc-cdn / cdn-base / Makefile
1 # New ports collection makefile for:    cdn-base
2 # Date created:                         25 Aug 2012
3 # Whom:                                 CyberLeo <cyberleo@cyberleo.net>
4 #
5 # $FreeBSD$
6 #
7
8 PORTNAME=       cdn-base
9 PORTVERSION=    1.0
10 CATEGORIES=     misc-cdn
11 MASTER_SITES=   # None
12 DISTFILES=      # None
13
14 MAINTAINER=     cyberleo@cyberleo.net
15 COMMENT=        Depends upon and helps configure ports installed by default
16
17 VALID_CATEGORIES += misc-cdn
18
19 NO_BUILD=       yes
20
21 OPTIONS_DEFINE= GIT PV
22 GIT_DESC=       Depend on devel/git
23 PV_DESC=        Depend on misc/pv for a progress bar
24 OPTIONS_DEFAULT=GIT PV
25
26 PLIST_FILES=    %%DATADIR%%/setup-cdn-base
27 SUB_FILES=      pkg-message setup-cdn-base
28
29 RUN_DEPENDS+=   portmaster:${PORTSDIR}/ports-mgmt/portmaster \
30                 ${LOCALBASE}/share/bash-config/fixuser:${PORTSDIR}/misc-cdn/bash-config \
31                 flag:${PORTSDIR}/misc-cdn/flag \
32                 sudo:${PORTSDIR}/security/sudo \
33                 rsync:${PORTSDIR}/net/rsync \
34                 screen:${PORTSDIR}/sysutils/screen
35
36 .include <bsd.port.options.mk>
37
38 .if ${PORT_OPTIONS:MGIT}
39 RUN_DEPENDS+=   git:${PORTSDIR}/devel/git
40 .endif
41
42 .if ${PORT_OPTIONS:MPV}
43 RUN_DEPENDS+=   pv:${PORTSDIR}/sysutils/pv
44 .endif
45
46 do-install: build
47         ${MKDIR} ${DATADIR}
48         ${INSTALL_SCRIPT} ${WRKDIR}/setup-cdn-base ${DATADIR}/setup-cdn-base
49
50 post-install:
51         @${CAT} ${PKGMESSAGE}
52
53 .include <bsd.port.mk>