]> CyberLeo.Net >> Repos - CDN/cdn-ports-overlay.git/blob - cdn/ports/misc-cdn/cdn-base/Makefile
misc-cdn/cdn-base: depend on portaudit
[CDN/cdn-ports-overlay.git] / cdn / ports / misc-cdn / cdn-base / Makefile
1 # New ports collection makefile for:    cdn-base
2 # Date created:                         25 Aug 2012
3 # Whom:                                 CyberLeo <cyberleo@cyberleo.net>
4 #
5 # $FreeBSD$
6 #
7
8 PORTNAME=       cdn-base
9 PORTVERSION=    1.0
10 PORTREVISION=   1
11 CATEGORIES=     misc-cdn
12 MASTER_SITES=   # None
13 DISTFILES=      # None
14
15 MAINTAINER=     cyberleo@cyberleo.net
16 COMMENT=        Depends upon and helps configure ports installed by default
17
18 VALID_CATEGORIES += misc-cdn
19
20 NO_BUILD=       yes
21
22 OPTIONS_DEFINE= GIT PV
23 GIT_DESC=       Depend on devel/git
24 PV_DESC=        Depend on misc/pv for a progress bar
25 OPTIONS_DEFAULT=GIT PV
26
27 PLIST_FILES=    %%DATADIR%%/setup-cdn-base
28 SUB_FILES=      pkg-message setup-cdn-base
29
30 RUN_DEPENDS+=   portaudit:${PORTSDIR}/ports-mgmt/portaudit \
31                 portmaster:${PORTSDIR}/ports-mgmt/portmaster \
32                 ${LOCALBASE}/share/bash-config/fixuser:${PORTSDIR}/misc-cdn/bash-config \
33                 flag:${PORTSDIR}/misc-cdn/flag \
34                 sudo:${PORTSDIR}/security/sudo \
35                 rsync:${PORTSDIR}/net/rsync \
36                 screen:${PORTSDIR}/sysutils/screen
37
38 .include <bsd.port.options.mk>
39
40 .if ${PORT_OPTIONS:MGIT}
41 RUN_DEPENDS+=   git:${PORTSDIR}/devel/git
42 .endif
43
44 .if ${PORT_OPTIONS:MPV}
45 RUN_DEPENDS+=   pv:${PORTSDIR}/sysutils/pv
46 .endif
47
48 do-install: build
49         ${MKDIR} ${DATADIR}
50         ${INSTALL_SCRIPT} ${WRKDIR}/setup-cdn-base ${DATADIR}/setup-cdn-base
51
52 post-install:
53         @${CAT} ${PKGMESSAGE}
54
55 .include <bsd.port.mk>